The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

malware acl condition - clamd

Discussion in 'E-mail Discussions' started by AnilR, Nov 28, 2007.

  1. AnilR

    AnilR Active Member

    Joined:
    Nov 24, 2007
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    I am receiving following error logs while looking at the exim_paniclog on the CentOS server:

    root@server [/home]# tail -f /var/log/exim_paniclog


    2007-11-27 23:25:47 1IxEUd-0004GY-AZ malware acl condition: clamd: unable to connect to UNIX socket /var/clamd (No such file or directory)

    2007-11-27 23:51:12 1IxEt9-0005Re-Ck malware acl condition: clamd: unable to read from socket (Connection reset by peer)

    2007-11-28 00:13:29 queue run: process 25009 crashed with signal 15 while delivering 1IxDQZ-0001V0-Fh
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Did you, by any chance, add this directive in the first box in EXIM advanced editor?:
    Code:
    "av_scanner = clamd:/var/clamd"
    If yes, remove it and restart exim. If not, or if that doesn't help, login to the WHM >> Main >> Service Configuration >> Exim Configuration Editor and click the button "Reset All Configs to Default". Now, if that doesn't help either, un-install and then re-install ClamAV.
     
  3. AnilR

    AnilR Active Member

    Joined:
    Nov 24, 2007
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    Hello Andy Reed...

    Its works like a charm...great stuff :)
     
  4. velda

    velda Well-Known Member

    Joined:
    Aug 24, 2005
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Utah
    Hi, sorry to reopen this thread - I ran into this on a server the other day, and these steps fixed the problem -- for the weekend. Same issue is back this morning.

    I've restarted exim again (and again its working) and am currently running a force update on cpanel. Has anyone else seen this problem recur and found a solution?
     
  5. chiefy

    chiefy Registered

    Joined:
    Dec 3, 2003
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I am having the same problem on a CentOS / cPanel VPS. Support has re-installed exim several times, ran checkperlmodules etc. and it seems that this happens every 24-48 hours. Restarting exim with /scripts/restartsrv_exim seems to fix the problem temporarily.

    I just received word from our support saying there isn't anythign they can do. Does anyone at cPanel realize that there is some kind of bug here? Is there any way to uninstall clamav ACL?
     
  6. velda

    velda Well-Known Member

    Joined:
    Aug 24, 2005
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Utah
    I'm sure you can disable it. In plugins under clamav you can set the options you want.

    I'm just not sure if I want it to stop scanning mail. Once I restart exim, the users get their mail that didn't come through earlier, so it's causing a little delay. But it's hard to consistently detect the problem without keeping a constant eye on it.
     
  7. bruceleeon

    bruceleeon Active Member

    Joined:
    Jul 20, 2004
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    I have been having this problem for quite some time now and it is VERY ANNOYING!!! I have been waiting for some sort of fix for months now and I haven't found anything that works long term.
     
Loading...

Share This Page