The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mandrill smart host issue

Discussion in 'E-mail Discussions' started by larishosting, Feb 2, 2014.

  1. larishosting

    larishosting Registered

    Joined:
    Mar 18, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I was able to get Mandrill setup on my server though smart host but our account was paused because paypal, LinkedIn, and other emails were being sent though as if we were sending them. A few of our clients have their work emails forwarding to their personal such as Gmail.

    Here's what mandrill support said.

    Quote
    Thanks for reaching out about this. Your account matched some of our abuse detection heuristics in part because it looks like emails from Paypal are being forwarded through your Mandrill account. In general, services like Paypal don't authorize third party servers to send emails "from" their domain, and relaying those emails through Mandrill can both impact your account reputation, but also our server reputation since they're not authorized to be sent through our servers by the sender domain.

    I've gone ahead and re-enabled sending for your account, though we do recommend an alternate approach for that type of mail rather than relaying it through Mandrill (ie, forwarding it directly, or changing the header information so that it's "from" you, or linking to the original). In general, only mail that you generate should be sent through Mandrill, and not email from outside sources since you can't control the content or types of mail that you may receive.
    This could also explain how we've got on spam list before because Gmail, comcast etc picked us up as sending spam when we're not.

    How can I set exim to forward the email without sending as paypal, LinkedIn, etc headers?

    Thank you for your help.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    It would likely require custom Exim filter rules to implement such functionality. You may want to consult with a system administration company if you do not receive user feedback on this subject:

    cPanel Application Catalog - System Admin Services

    Thank you.
     
  3. JacobHansen

    JacobHansen Member

    Joined:
    Mar 20, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    There is a "senders" routers option which might be useful for ignoring your mandril relay. However this option requires a full set of e-mail addresses, it would be better if it could be done per domain level, so you could use the local_domains variable.

    if you figure it out please share, having the same problem.
     
  4. JacobHansen

    JacobHansen Member

    Joined:
    Mar 20, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Try adding this to your router, seems to work pretty well.

    condition = ${lookup {$sender_address_domain} \
    lsearch {/etc/localdomains} {yes}}
     
Loading...

Share This Page