ougogo

Well-Known Member
Dec 28, 2012
52
1
58
cPanel Access Level
Root Administrator
Hi all !

This is my statistics software configuration :
whm-1.png

But when I select an user by clicking on "Choose which specific users can modify their web generating software.", the user can't select Awstats.
But all users can when I select "Allow all users to change their web statistics generating software.".

I want that just authorized users can use Awstats software.


Thanks in advance !
 

quietFinn

Well-Known Member
Feb 4, 2006
1,649
323
438
Finland
cPanel Access Level
Root Administrator
I was testing this, and couldn't get it to work either.
Seems like a bug for me.
 

CitizenK

Well-Known Member
Jun 5, 2012
64
1
58
On The Road
cPanel Access Level
Root Administrator
Ahoy,

Our investigation into this issue has reveled that this issue can be worked around by changing the settings userstatsoverride setting in /var/cpanel/cpanel.conf from 0 to 1.

You will want to make sure that your /var/cpanel/cpanel.conf file looks like this:
Code:
userstatsoverride=1
This will enable users that you have enabled to select the stats programs that they have enabled for their account.
 

ougogo

Well-Known Member
Dec 28, 2012
52
1
58
cPanel Access Level
Root Administrator
Hi

I've change my "/var/cpanel/cpanel.config" but no result.
With the same configuration show on my screenshot first post, users normally allowed to change their stats programm can't do.

And with I check "Allow all users to change their web statistics generating software.", the users could choose, but after they can't acces to Awstats. Why ? Is there any waiting ?

It is written on Awstats page :

No area has awstats stats available.

Should I reload any service ?



Thanks.
 

quietFinn

Well-Known Member
Feb 4, 2006
1,649
323
438
Finland
cPanel Access Level
Root Administrator
I changed the setting in /var/cpanel/cpanel.config to:
userstatsoverride=1
restarted cPanel, and after that the setting was back to:
userstatsoverride=0