The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Manually send an email again to who over disk quota

Discussion in 'E-mail Discussions' started by ChrisDev, Aug 8, 2016.

  1. ChrisDev

    ChrisDev Member

    Joined:
    Aug 8, 2016
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sydney
    cPanel Access Level:
    Root Administrator
    Hi All,


    I'm an admin of couple of VPSs.

    Some clients want to increase their disk quota to delete some emails for reducing disk quota when they are over using it.
    But when I check their disk quota after few days later. nothing changed.

    So I would like to remind them using disk over quota email template.

    Is there any script to send disk over quota email manually?


    Best Regards,
    Chris
     
  2. SysSachin

    SysSachin Well-Known Member

    Joined:
    Aug 23, 2015
    Messages:
    322
    Likes Received:
    23
    Trophy Points:
    18
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    You have to enable notification in WHM using following steps so that you will get email.

    Login to WHM >> Server Configuration >> Tweak Settings >> Notification
    1) System disk space usage warnings
    2)Account system disk usage “warn” percentage
     
  3. ChrisDev

    ChrisDev Member

    Joined:
    Aug 8, 2016
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sydney
    cPanel Access Level:
    Root Administrator

    Hi SysSachin,

    Thanks for the reply, I did it already. It works well.

    But I'd like to send an email notification manually as well.


    Best Regards,
    Chris
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Yes, you can manually generate the notifications with the following command:

    Code:
    /usr/local/cpanel/scripts/quotacheck
    Notification data is stored in the following directory:

    /var/cpanel/notifications/

    Thank you.
     
    ChrisDev likes this.
  5. ChrisDev

    ChrisDev Member

    Joined:
    Aug 8, 2016
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sydney
    cPanel Access Level:
    Root Administrator
    Hi Michael,

    Thanks for your reply, I did that command and the result is a bit strange. also the email isn't sent.

    Code:
    [ ~]# /usr/local/cpanel/scripts/quotacheck
    [quotacheck] Setting I/O priority to reduce system load: none: prio 0
    
    What's the meaning?

    Is there any options should I use for this command?

    Best Regards,
    Chris
     
    #5 ChrisDev, Aug 9, 2016
    Last edited: Aug 9, 2016
  6. ChrisDev

    ChrisDev Member

    Joined:
    Aug 8, 2016
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sydney
    cPanel Access Level:
    Root Administrator
    When I ran with below options, I was still facing similar error result. :(

    Code:
    [ ~]# /usr/local/cpanel/scripts/quotacheck -avugm
    [quotacheck] Setting I/O priority to reduce system load: none: prio 4
    
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Are you sure an account meets the notification criteria? For instance, I set one account to reach 80% of it's quota, browsed to the "Notifications" tab in "WHM >> Tweak Settings", and set the following option to "80":

    "Account system disk usage “warn” percentage"

    I then ran the "/usr/local/cpanel/scripts/quotacheck" command and noticed the new entry in /var/log/exim_mainlog and in the "/var/cpanel/quotawarned" file, showing the warning notification was sent.

    Thank you.
     
  8. ChrisDev

    ChrisDev Member

    Joined:
    Aug 8, 2016
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sydney
    cPanel Access Level:
    Root Administrator
    Hi Michael,

    Thank you for the reply.




    Yes, I'm pretty sure about the account meets the notification criteria.

    Automatical notifications of each criteria such as warning, critical and so on are find, well sent .
    The problem is when I run the command
    Code:
    /usr/local/cpanel/scripts/quotacheck
    .

    Nothing's happened when I check the exim_maillog
     
  9. ChrisDev

    ChrisDev Member

    Joined:
    Aug 8, 2016
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sydney
    cPanel Access Level:
    Root Administrator
    Hi Michael,


    I resolved it.

    I found if there is no "/var/cpanel/quotawarned" file then quotacheck command is working. So I delete that file and then "/usr/local/cpanel/scripts/quotacheck" command send notification email again.

    I'm not sure it is a normal behaviour of the quotacheck command's working like that.

    Anyway thank you for your help.

    Best Regards,
    Chris
     
    #9 ChrisDev, Aug 21, 2016
    Last edited: Aug 22, 2016
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page