Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

MariaDB 10.0 or Stay with MySQL

Discussion in 'Database Discussion' started by vlee, Feb 4, 2015.

  1. vlee

    vlee Well-Known Member

    Joined:
    Oct 13, 2005
    Messages:
    348
    Likes Received:
    23
    Trophy Points:
    168
    Location:
    Spokane, Washington
    cPanel Access Level:
    Root Administrator
    I do not know which way I should go on this topic. So I will like to get everyone's input here.

    I know for one thing. I am the type person that is want high security, speed, performance, lots of features and all around functionality that will work with everything or at least almost everything.

    MySQL 5.5

    MySQL 5.6

    MariaDB 10.0

    Also it say's "After you upgrade MySQL/MariaDB, there is no supported way to downgrade to the previous version" so if I do upgrade I need to make sure that I am making the right choice.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,711
    Likes Received:
    1,794
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello :)

    You will find several reasons why users prefer MariaDB in it's feature request:

    MariaDB support | cPanel Feature Requests

    The feature is already implemented, but the comments section contain user opinions that you may find helpful.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. vlee

    vlee Well-Known Member

    Joined:
    Oct 13, 2005
    Messages:
    348
    Likes Received:
    23
    Trophy Points:
    168
    Location:
    Spokane, Washington
    cPanel Access Level:
    Root Administrator

    Thank you Michael

    My concern is that if I switch to MariaDB is sites stop working and users start complaining that there sites are down.

    Does phpMyAdmin work with MariaDB?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. ES - George

    ES - George Well-Known Member
    PartnerNOC

    Joined:
    Jun 12, 2011
    Messages:
    141
    Likes Received:
    2
    Trophy Points:
    68
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    I've upgraded a good 50+ systems from MySQL 5.6 -> MariaDB 10 using the supported cPanel method and there have been no problems, other than one customer who was using Oxwall. The script checked for MySQL version 5.0 or higher, but didn't seem to recognize the existence of MariaDB

    phpMyAdmin does indeed work with MariaDB.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    Kent Brockman likes this.
  5. vlee

    vlee Well-Known Member

    Joined:
    Oct 13, 2005
    Messages:
    348
    Likes Received:
    23
    Trophy Points:
    168
    Location:
    Spokane, Washington
    cPanel Access Level:
    Root Administrator
    I have now MariaDB 10.0 running on one of my servers and seems to be functioning great and WHMCS loads up fine.

    Now I will do slowly do the rest of the servers.

    Thank you cPanel staff
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    Kent Brockman likes this.
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice