MariaDB 10.2 to 10.3 upgrade issues

Greg M

Active Member
May 26, 2016
43
13
58
Glasgow, Scotland
cPanel Access Level
Root Administrator
Tried doing it via WHM, failed with an error so I tried to check via YUM and this is what I get. At the end checking mysql --version shows me 10.3 but as far as everything else is concerned (WHM) I'm still 10.2


This is a Centos 6 machine and I was trying to import the configuration to a new machine I'm setting up on AWS with Centos 7 but it preinstalled 10.3 so it wont run the transfer






[[email protected] ~]# yum update -y
Loaded plugins: security, tsflags, universal-hooks
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package MariaDB-server.x86_64 0:10.2.32-1.el6 will be updated
---> Package MariaDB-server.x86_64 0:10.3.23-1.el6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Updating:
MariaDB-server x86_64 10.3.23-1.el6 MariaDB103 135 M

Transaction Summary
================================================================================
Upgrade 1 Package(s)

Total download size: 135 M
Downloading Packages:
MariaDB-server-10.3.23-1.el6.x86_64.rpm | 135 MB 00:08
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction

******************************************************************
A MySQL or MariaDB server package (MariaDB-server-10.2.32-1.el6.x86_64) is installed.

Upgrading directly from MySQL 10.2 to MariaDB 10.3 may not
be safe in all cases. A manual dump and restore using mysqldump is
recommended. It is important to review the MariaDB manual's Upgrading
section for version-specific incompatibilities.

A manual upgrade is required.

- Ensure that you have a complete, working backup of your data and my.cnf
files
- Shut down the MySQL server cleanly
- Remove the existing MySQL packages. Usually this command will
list the packages you should remove:
rpm -qa | grep -i '^mysql-'

You may choose to use 'rpm --nodeps -ev <package-name>' to remove
the package which contains the mysqlclient shared library. The
library will be reinstalled by the MariaDB-shared package.
- Install the new MariaDB packages supplied by MariaDB Foundation
- Ensure that the MariaDB server is started
- Run the 'mysql_upgrade' program

This is a brief description of the upgrade process. Important details
can be found in the MariaDB manual, in the Upgrading section.
******************************************************************
error: %pre(MariaDB-server-10.3.23-1.el6.x86_64) scriptlet failed, exit status 1
Error in PREIN scriptlet in rpm package MariaDB-server-10.3.23-1.el6.x86_64
error: install: %pre scriptlet failed (2), skipping MariaDB-server-10.3.23-1.el6
/etc/yum/universal-hooks/pkgs/MariaDB-server/posttrans/100-build_mysql_conf: running in the background.
Verifying : MariaDB-server-10.3.23-1.el6.x86_64 1/2
MariaDB-server-10.2.32-1.el6.x86_64 was supposed to be removed but is not!
Verifying : MariaDB-server-10.2.32-1.el6.x86_64 2/2

Failed:
MariaDB-server.x86_64 0:10.2.32-1.el6 MariaDB-server.x86_64 0:10.3.23-1.el6

Complete!
[[email protected] ~]# mysql --version
mysql Ver 15.1 Distrib 10.3.23-MariaDB, for Linux (x86_64) using readline 5.1
[[email protected] ~]#
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,266
313
Houston
Can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


Thanks!
 

Greg M

Active Member
May 26, 2016
43
13
58
Glasgow, Scotland
cPanel Access Level
Root Administrator
Thanks but I will skip the ticket for now - reason below

I was intending on just quickly migrating but as this is going to clearly take time (there were other things to resolve) it is not worth the hassle when Centos 8 support is hopefully round the corner, I'd rather not migrate twice when a direct jump to 8 will keep us going for several years.