The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Marvellous! Install is broken?

Discussion in 'General Discussion' started by movielad, Aug 30, 2005.

  1. movielad

    movielad Well-Known Member
    PartnerNOC

    Joined:
    May 14, 2003
    Messages:
    107
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    DataCenter Provider
    Code:
    Fetching [url]http://httpupdate.cpanel.net/pub/CPAN/index.html[/url] (0)....@69.72.164.151......connected......receiving...69%...100%......Done
    Linux detected!
    cPanel Layer 1 Installer Init.....
    Warning !!! Warning !!! WARNING !!! Warning !!! Warning
    -------------------------------------------------------
    cPanel requires a fresh/clean server!
    If you are serving websites off this server (and are
    not already running cPanel) this installer will
    overwrite all of your config files.  You should hit
    Ctrl+C NOW!!!
    If this is a new server please ignore this messages
    -------------------------------------------------------
    Warning !!! Warning !!! WARNING !!! Warning !!! Warning
    Waiting 5 seconds........Done
    This install will take 10-70 minutes depending on your hardware.
    Now is the time to go get another cup of coffee/jolt.
    The install will log to /var/log/cpanel-install-thread0.log.
    and /var/log/cpanel-install-thread1.log.
    Installing...1......x1...2...........x2...3...4......x4...5.......x5.........x3...6.......x6..7...................x7..8.......x8......waiting for cpanelsync to finish......waiting for cpanelsync to finish......waiting for cpanelsync to finish......waiting for cpanelsync to finish.
    
    And:

    Code:
    root@opteron cpins]# tail /var/log/cpanel-install-thread0.log
    error: package mysql-devel is not installed
    error: package mysql-server is not installed
    error: package wu-ftpd is not installed
    error: package postfix is not installed
    error: package sendmail is not installed
    error: package smail is not installed
    sendmail: no process killed
    postfix: no process killed
    master: no process killed
    open3: exec of /scripts/mailperm failed at ./install line 609
    [root@opteron cpins]# tail /var/log/cpanel-install-thread1.log
    cPanel install started at: Tue Aug 30 12:28:09 2005!
    cPanel install started at: Tue Aug 30 12:28:54 2005!
    Can't locate cPScript/RpmUtils.pm in @INC (@INC contains: /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 . /scripts) at /scripts/ensurerpm2 line 17.
    BEGIN failed--compilation aborted at /scripts/ensurerpm2 line 17.
    cPanel install started at: Tue Aug 30 08:30:37 2005!
    Can't locate cPScript/RpmUtils.pm in @INC (@INC contains: /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 . /scripts) at /scripts/ensurerpm2 line 17.
    BEGIN failed--compilation aborted at /scripts/ensurerpm2 line 17.
    cPanel install started at: Tue Aug 30 08:32:28 2005!
    Can't locate cPScript/RpmUtils.pm in @INC (@INC contains: /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 . /scripts) at /scripts/ensurerpm2 line 17.
    BEGIN failed--compilation aborted at /scripts/ensurerpm2 line 17.
    And cPanel aren't open until the afternoon UK time, leaving me with a server I can't use! I'm trying to install on a clean CentOS 3.5 server (32-bit). Never had any trouble before..

    M.
     
  2. silversurfer

    silversurfer Well-Known Member

    Joined:
    Dec 29, 2002
    Messages:
    274
    Likes Received:
    0
    Trophy Points:
    18
    Yup. Had issues this morning with this. We love Cpanel. :)
     
  3. movielad

    movielad Well-Known Member
    PartnerNOC

    Joined:
    May 14, 2003
    Messages:
    107
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    DataCenter Provider
    Perhaps prices should be raised so that cPanel can get an emergency on-call developer or something ;)

    M.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    When you installed CentOS did you also install the yum CentOS 3.5 gnupg key and ensure that yum was working correctly before attempting to install cPanel?
     
  5. movielad

    movielad Well-Known Member
    PartnerNOC

    Joined:
    May 14, 2003
    Messages:
    107
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    DataCenter Provider
    Yes to all accounts. Re-imported the key again to play it safe, and it didn't work.

    M.
     
    #5 movielad, Aug 30, 2005
    Last edited: Aug 30, 2005
  6. movielad

    movielad Well-Known Member
    PartnerNOC

    Joined:
    May 14, 2003
    Messages:
    107
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    DataCenter Provider
    Now seems to be working thanks to cpanelben.

    M.
     
  7. tomsyer

    tomsyer Active Member

    Joined:
    Aug 5, 2003
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Seems to be still an issues for the two servers I am attmepting to install.
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Try running:

    killall -9 safeapacherestart

    Apache restart can get into a deadlock unless you're running CURRENT and above.

    An alternative method, if this is a new install, is given by Ben here:
    http://forums.cpanel.net/showthread.php?t=43296
     
    #8 chirpy, Aug 30, 2005
    Last edited: Aug 30, 2005
Loading...

Share This Page