The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mass nobody email to root email!

Discussion in 'E-mail Discussions' started by Kh@lid, Aug 25, 2005.

  1. Kh@lid

    Kh@lid Member

    Joined:
    Apr 29, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I'm getting a mass of nobody emails from my server to the root email! These email are from all the users who use vBulletin forums.

    All emails are received as
    From: Mail Delivery System [Mailer-Daemon@HOST.NAME.com]
    To: root@HOST.NAME.COM


    Thanks in advance.

    Khalid
     
  2. fred123123

    fred123123 Well-Known Member

    Joined:
    Jul 23, 2005
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    when mail is returned to sender... in your case nobody, root will receive it...
     
  3. Kh@lid

    Kh@lid Member

    Joined:
    Apr 29, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    But it wasn't like that before I moved the accounts to a new server!
    Any Idea how to stop receiving these emails? I have to empty the inbox every hour!
     
    #3 Kh@lid, Aug 25, 2005
    Last edited: Aug 25, 2005
  4. WORLD

    WORLD Member

    Joined:
    Jun 9, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    same here

    We also received over 8000 nobody@cp.our-name.com.
    We were told to go into WHM and then >> Tweak Settings Then check off >> Prevent the user 'nobody' from sending out mail to remote addresses (php and cgi scripts generally run as nobody if you are not using phpsuexec and suexec respectively.)

    Didn't seem to work, so we then cleaned out all of the existing emails under WHM >> Email >> Mail Queue Manager.

    Seem to help!
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The nobody bounces go to whatever address you have set for WHM > Change System Mail Preferences > nobody's email. If you're receiving that many bounces you should investigate them very carefully to ensure that you don't have a spammer on the server exploiting a PHP script.
     
  6. Kh@lid

    Kh@lid Member

    Joined:
    Apr 29, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Thanks guys...

    Under Nobody email field I didn't put any email address! I even tried to put an email address and nothing was received in it.

    If I disabled nobody, the forums program (vBulletin) can't send any notification to their users. BTW, I don't have phpsuexec but suexec is enabled.

    In my previous servers, everythind was the same and all nobody emails were in the Mail Queue Manager only, but I didn't get any nobody emails to the root email! I don't know if it is related to the cPanel version or any other thing!?

    The root email is only assigned under root email and cPanel email.
    I even tried to remove it from the cPanel and still receiving this huge mass of nobody emails, so I decided to keep it there just incase.

    Any idea or help will be highly appreciated.


    Khalid
     
  7. BuffaloWeb

    BuffaloWeb Well-Known Member

    Joined:
    Jul 1, 2003
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Same issue here - getting slammed by bounced messages off of a vBulletin forum on a dedictaed server (forum is quite large).

    1. "Prevent the user 'nobody' from sending out mail to remote addresses" is not disabled (unchecked)

    2. nobody's mail is "currently not being forwarded"

    Should nobody's mail be forwarded to dev/null? :fail: no such address here? :blackhole:? I hate to do that really - I'd rather fix the problem...

    Is there some setting in vBulletin that perhaps causes this?
     
  8. ghv

    ghv Well-Known Member

    Joined:
    Oct 18, 2003
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    I'm getting this as well on an FC4 box but no others - all my boxes have a similar setup.

    In 'system email preferences' on this box, it is not possible to save any forwarding addresses except for root email. Text input fields just show up as empty after trying to set forwarding addresses for other system mail.

    Can anyone confirm the same problem? I'll check Bugzilla when I have a minute.

    Running 10.8.0-C74.
     
  9. PortugalNetwork

    Joined:
    Jan 9, 2005
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Having the same problem, and nobody seems to know what is going on.

    cPanel staff say to change the setings, but the settings are correct, but it does not work.
     
  10. ThunderHostingDotCom

    ThunderHostingDotCom Well-Known Member

    Joined:
    Nov 18, 2002
    Messages:
    450
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    All over!
    Having the same problem here! Any fix for this yet?
     
  11. Morgana

    Morgana Active Member

    Joined:
    Jan 16, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    The same problem here. It really seems that nobody knows what is going on. I am using WHM 10.8.0 cPanel 10.8.1-S31 and it is only one box that has this problem.
     
  12. Morgana

    Morgana Active Member

    Joined:
    Jan 16, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Could it be a problem with WHM 10.8.0? My other servers have a lower version and there are no problems there.
     
  13. ffeingol

    ffeingol Well-Known Member
    PartnerNOC

    Joined:
    Nov 9, 2001
    Messages:
    215
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    DataCenter Provider
    We've been having similar issues. Setting the "nobody" mail to blank or /dev/null had no effect.

    From the forum point of view what is happening is that someone is replying to a thread. On that thread someone is "watching" the thread that has a bad email address. If you have some very popular threads or a person watching a lot of threads that has left the board/bad email address you can get 100's - 1000's of emails per day.

    Frank
     
  14. BuffaloWeb

    BuffaloWeb Well-Known Member

    Joined:
    Jul 1, 2003
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    We think ours was the result of having a user with a vBulletin install configured improperly. We had to make sure that the various admin contact emails within vBulletin were set to existing addresses (I think they had something going to "webmaster@xxx" which was an email account that they did not actually have set up). :rolleyes:

    We also set "Enable "-f" Parameter" to On...

    Problem resolved for us, although it is apparent that there is still an issue with the WHM "nobody" settings...
     
  15. ffeingol

    ffeingol Well-Known Member
    PartnerNOC

    Joined:
    Nov 9, 2001
    Messages:
    215
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    DataCenter Provider
    Where is this option? Can't find it in WHM :(

    Frank
     
  16. ckoepf

    ckoepf Registered

    Joined:
    Mar 29, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Strykersville, NY
    Check for a "X-Source-Dir:" line in your returned mail headers. I found a folder on my server that had some scripts in it that were being excecuted and that's where the message stemmed from. I stopped it right after it started yesterday morning and got 941 returned emails. Only couple since then from a few slow mail servers. And I don't use vBulletin.
     
  17. procam

    procam Well-Known Member

    Joined:
    Nov 24, 2003
    Messages:
    123
    Likes Received:
    0
    Trophy Points:
    16

    I have this problem now as well on a brand new build FC2 the unit refuses to allow me to set a forwarding address for nobody and cpanel's mail - if I put an address in the filed and save when I go back its still empty!!!
    How bout it anyone have a fix for this ? Its not any bulliten boards or scripts theres nothing on the box yet!~
     
  18. BuffaloWeb

    BuffaloWeb Well-Known Member

    Joined:
    Jul 1, 2003
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    That was an option in vBulletin that I was referring to...
     
  19. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If you have a look at the changelog and the bugzilla entries fixed, there's a fix in. You'll have to wait for it to percolate down to the release tree you're using or go to EDGE.
     
  20. DrZEUS

    DrZEUS Active Member

    Joined:
    Jan 24, 2004
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    hi is there a resolution for this?
     
Loading...

Share This Page