The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Max files help - urgent

Discussion in 'General Discussion' started by phantom, Apr 10, 2003.

  1. phantom

    phantom Well-Known Member

    Joined:
    Sep 17, 2002
    Messages:
    123
    Likes Received:
    0
    Trophy Points:
    16
    I'm on a
    P4 2.0 GHZ with a gig of DDR Ram
    and at 2mbps, apache is crashing.

    I'm getting this message:

    [maxfilescheck] Apache on has exceeded the maximum amount of open files

    how can I increase the max files that can be opened?

    Here's my error log

    Failed loading /usr/local/Zend/lib/ZendOptimizer.so: /usr/local/Zend/lib/ZendOptimizer.so: cannot open shared object file: No such file or directory
    [Thu Apr 10 08:14:52 2003] [notice] Apache/1.3.27 (Unix) mod_log_bytes/1.0 mod_bwlimited/1.0 PHP/4.3.1 FrontPage/5.0.2.2510 mod_ssl/2.8.12 OpenSSL/0.9.6b configured -- resuming normal operations
    [Thu Apr 10 08:14:52 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Thu Apr 10 08:14:52 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)
    [Thu Apr 10 08:15:06 2003] [error] server reached MaxClients setting, consider raising the MaxClients setting
    [Thu Apr 10 08:15:39 2003] [notice] SIGHUP received. Attempting to restart
    Failed loading /usr/local/Zend/lib/ZendOptimizer.so: /usr/local/Zend/lib/ZendOptimizer.so: cannot open shared object file: No such file or directory
    [Thu Apr 10 08:15:39 2003] [notice] Apache/1.3.27 (Unix) mod_log_bytes/1.0 mod_bwlimited/1.0 PHP/4.3.1 FrontPage/5.0.2.2510 mod_ssl/2.8.12 OpenSSL/0.9.6b configured -- resuming normal operations
    [Thu Apr 10 08:15:39 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Thu Apr 10 08:15:39 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)

    Thanks
     
    #1 phantom, Apr 10, 2003
    Last edited: Apr 10, 2003
  2. ckevin

    ckevin Member

    Joined:
    Jan 17, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    you are not alone, my server also has this problem, but it seems i can't find any solutions by searching the cpanel support forum.. :rolleyes:
     
  3. vishal

    vishal Well-Known Member

    Joined:
    Jan 28, 2003
    Messages:
    340
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    This may Help!!!

    Hello,

    Failed loading /usr/local/Zend/lib/ZendOptimizer.so: /usr/local/Zend/lib/ZendOptimizer.so: cannot open shared object file: No such file or directory

    /script/updatenow (Just to be sure that u'll have latest scripts)

    /scripts/installzendopt

    Should solve the above!!! :)

    [Thu Apr 10 08:15:06 2003] [error] server reached MaxClients setting, consider raising the MaxClients setting

    MaxClients ??? (Increase this )

    in httpd.conf


    Hope this helps!!!

    Regards,
    :p
     
  4. phantom

    phantom Well-Known Member

    Joined:
    Sep 17, 2002
    Messages:
    123
    Likes Received:
    0
    Trophy Points:
    16
    I found out what my problem was. I run a free host. I deleted some guys site from Japan for breaking the rules. He signed up to another account, uploaded 1000 300k fules and started requesting them all as fast as he could. I blocked Japan alltogether. Problem solved.
     
  5. vishal

    vishal Well-Known Member

    Joined:
    Jan 28, 2003
    Messages:
    340
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Did you block the requests that come from Japan? If yes how?
     
Loading...

Share This Page