Operating System & Version
CloudLinux 7
cPanel & WHM Version
v98.0.9

Tarak Nath

Well-Known Member
Mar 12, 2018
97
14
8
India
cPanel Access Level
Root Administrator
Hello,

Due to the "max_children" reached 25 while many user are using webmail under a domain we have increased the "max_children" to 100 as there are more than 60 users are uses webmail in our peak hours.

But the said value returns to 25 once new cPanel updated or server rebooted.
We are using PHP-FPM along with CloudLinux and the current cPanel version is v98.0.9.

Please let us know if there is any permanent solutions.

Regards,
 

Tarak Nath

Well-Known Member
Mar 12, 2018
97
14
8
India
cPanel Access Level
Root Administrator
Hello,

Using root SSH access for the both as mentioned below:

Code:
/usr/local/cpanel/src/templates/cpanel_php_fpm/user.default
/var/cpanel/php-fpm.d/cpanelaccountname.conf
Regards,
 

cPanelAnthony

Administrator
Staff member
Oct 18, 2021
656
62
103
Houston, TX
cPanel Access Level
Root Administrator
My apologies for any confusion. I see you need the internal PHP settings for cPanel changed, not the FPM pool options per domain. At the very least, settings changed here wouldn't help.

/var/cpanel/php-fpm.d/cpanelaccountname.conf

In order to help further, can you confirm which log file you found these max children errors in? Thank you!
 

Tarak Nath

Well-Known Member
Mar 12, 2018
97
14
8
India
cPanel Access Level
Root Administrator
Hello,

Actually many users are reports that they are facing issue with webmail ( Roundcube) for a specific domain.
They mainly reports as following:
===================
1. Most of the time its showing server error.
2. Its taking too much time to load the page or switching folder or another menu (i.e Mail to Settings, Inbox to Sent)
===================
They are using the mentioned below URLs:
https://server.hostname.com:2096

Issue is persist for both URLs. In our investigation we found that in our business hours, when 70-80 users are using webmail at the same time simultaneously then this issue has occurred.

We have checked the log [ /usr/local/cpanel/logs/php-fpm/error.log ] and found something like:

Code:
server reached max_children setting (25)
Then we have increased the value from 25 to 100 but they get reset to previous/default value to 25 once new cPanel updated or server rebooted. And this is 3rd time the said value reset to previous/default value.

For this issue we had contacted with our hosting provider, even they also contacted with cPanel support via a ticket previously in last April. In that time they mentioned as following:
=================
Per their recommendation, we have modified the default max_children for the internal PHP-FPM service utilized by cPanel services (such as webmail) which should address this issue
=================
But now again same issue occurred due to cPanel update/server rebooted, we have contacted again with our provider and now this time they are saying that there is no permanent solution while using PHP-FPM service. Also they advised to disable PHP-FPM service for permanent solution otherwise we must have to modify every time when cPanel updated or server rebooted.

We came here with very frustration if we could find a permanent solutions. Please suggest.

Reagards,
 

cPanelAnthony

Administrator
Staff member
Oct 18, 2021
656
62
103
Houston, TX
cPanel Access Level
Root Administrator
I completely understand the frustration; issues like this can be quite crippling for a server. In order to give your specific issue a thorough investigation, would you be able to open a ticket with cPanel support using the link in my signature? Once done, please update me with the ID so I can provide a solution here once one is reached.