Nov 11, 2018
6
0
1
Australia
cPanel Access Level
Root Administrator
Hi

I have an issue where the max_user_connections for a user resets back to 30 and I can't see why.

mysql Ver 15.1 Distrib 10.0.38-MariaDB, for Linux (x86_64) using readline 5.1

I update the variable with "UPDATE mysql.user SET max_user_connections = 80 WHERE user='xxxxx AND host='localhost';" and it is applied fine when I check it afterwards, but each day I get a message from him saying it's reset back to 30 again.

I can't see what is making it reset back to 30.

my.cnf file

[mysqld]
max_user_connections=300
max_allowed_packet=268435456
open_files_limit=23000
 
Nov 11, 2018
6
0
1
Australia
cPanel Access Level
Root Administrator
Sorry, logging wasn't enabled. I've got it logging now so I can see what happens overnight and see if I can tell where it switches the user back to 30.

Funny thing is, I can set the user to 80 max_user_connections and restart mysql and it stays at 80. Could the user themselves be setting it back to 30 in a script they use?
 
Nov 11, 2018
6
0
1
Australia
cPanel Access Level
Root Administrator
Hi. There is nothing in the error log overnight. I'm at a loss. There must be something that happens overnight (I assume during maintenance) that resets the user back to 30. As I said, I can set it and restart mysqld and it stays at 80, but next morning it's back to 30. Should I up the level of connections in the my.cnf to 500?
 
Nov 11, 2018
6
0
1
Australia
cPanel Access Level
Root Administrator
Entire my.cnf is below

[mysqld]
# performance-schema=0
# default-storage-engine=MyISAM
# innodb_file_per_table=1
# open_files_limit=50000
# max_sessions = 500
log_error=/var/log/mysqld.log
max_user_connections=300
max_allowed_packet=268435456
open_files_limit=23000

We only have 2 users we have to set to a higher than standard connections as they are running 2 x CMS programs, but they are both on the same cpanel account. It happens to both of them.
 
Thread starter Similar threads Forum Replies Date
V Database Discussion 5