The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mbstring error

Discussion in 'General Discussion' started by Brandonm, Sep 2, 2003.

  1. Brandonm

    Brandonm Active Member

    Joined:
    Aug 31, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    I am posting here because the support form has taken to long to get anything done about the problem. If anyone has any suggestions please let me know. There error is:

    You are using PHP 4.2.3, which has a serious bug with multi-byte strings (mbstring). See PHP bug report 19404. This version of PHP is not recommended for use with phpMyAdmin.

    It seems as if the update for cpanel to the latest stable version screwed over the php on the webserver. There are two locations for phpmyadmin and two locations for the php I am assuming. In cpanel it tells me 4.3.2.. In phpmyadmin it tells me the error above.

    the php that phpmyadmin is using is in /usr/local/cpanel/3rdparty

    the one for apache is in /usr/local/bin

    cPanel.net Support Ticket Number:
     
  2. Doctor

    Doctor Well-Known Member

    Joined:
    Apr 26, 2003
    Messages:
    180
    Likes Received:
    0
    Trophy Points:
    16
    Try recompiling Apache (/scripts/easyapache Option 1).

    cPanel.net Support Ticket Number:
     
  3. Brandonm

    Brandonm Active Member

    Joined:
    Aug 31, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    tried.. and was told to try the latest edge version.. that didnt work either so I went back to the latest stable version. Same thing.

    cPanel.net Support Ticket Number:
     
  4. Doctor

    Doctor Well-Known Member

    Joined:
    Apr 26, 2003
    Messages:
    180
    Likes Received:
    0
    Trophy Points:
    16
    Apparently, this has to do with corrupted mb strings. What I suggest you to do is:

    1. Login to WHM, under Software, click Update Apache.
    2. Untick/deselect MB Strings
    3. Click BUILD.

    Once Apache is rebuilt, do the following:

    1. Login to WHM, under Software, click Update Apache.
    2. Tick/Select MB Strings (and any other modules that you might want to include)
    3. Click BUILD.

    If everything goes well, this should work for you. Make sure you are running the CPANEL STABLE version. Good luck!

    cPanel.net Support Ticket Number:
     
  5. Doctor

    Doctor Well-Known Member

    Joined:
    Apr 26, 2003
    Messages:
    180
    Likes Received:
    0
    Trophy Points:
    16
    I just noticed that you are using PHP 4.2.3? When you rebuild Apache, make sure you DO NOT TICK/SELECT "Downgrade to version 4.2.3".

    cPanel.net Support Ticket Number:
     
  6. Brandonm

    Brandonm Active Member

    Joined:
    Aug 31, 2003
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    already checked that. cpanel seemed to have fixed the issue for me.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page