The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MediaWiki, CPanel Add on Domain and Apache

Discussion in 'EasyApache' started by rec9140, Jun 7, 2007.

  1. rec9140

    rec9140 Registered

    Joined:
    Jun 7, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Host: Hostgator

    Linux
    Kernel version 2.6.17.11-grsechg
    Machine Type i686
    Apache version 1.3.37 (Unix)
    PERL version 5.8.8
    PHP version 4.4.4
    MySQL version 4.1.21-standard
    cPanel Build 10.9.0-RELEASE 10737
    Theme cPanel X v2.6.0

    Mediawiki: MediaWiki 1.4.14
    PHP 4.4.4 (cgi)
    MySQL 4.1.21-standard-log


    Root:

    public_html
    main domain files & dirs
    addondomain ( dir)
    wiki (dir)
    mediawiki files & dirs i

    I can NOT change the MW version I am tied to a custom monobook skin that is not compatible with later versions.

    The problem:

    I have a main domain and then another domain thats being used as an add
    on
    domain since HG allows unlimited domains on one plan.

    Installing the wiki to the host all is fine, TILL I try to use the domain
    for
    the site.

    http://www.addon.invalid (.htaccess redirects to /wiki sub dir)

    http://www.addon.invalid/wiki/

    Are FINE for the MAIN PAGE and Special Pages, but any thing else on the
    wiki
    gets urls like:

    http://www.addon.invalid/addon/wiki/.....

    Which just FUBAR's things up royally, taking out the extra /addon/ in the
    URL's
    things come up fine. And the problem is present with or with out the
    .htaccess
    redirect

    Using:
    http://www.maindomain.invalid/addon/wiki

    Works for all pages, but has no "skin" to it.

    A post on some MW sites mentioned $WScriptPath, but that is
    set to what the post indicated corrected the problem wiki/

    Possibly Mod Rewrites to resolve this? ? ?

    Any one else deal with this issue as I think its Apache & CPanel causing
    this problem of adding in the /addon/ to the links past the main page and
    special pages.

    Any one have some help on this as its really becoming a big problem and huge thorn in my side.
     
Loading...

Share This Page