Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Memcache and Memcached in EA 4

Discussion in 'EasyApache' started by ribo, Nov 11, 2015.

  1. ribo

    ribo Well-Known Member

    Joined:
    Oct 15, 2015
    Messages:
    60
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    Hello,
    I have compiled different versions of memcache:
    latest 3.0.8 (beta) and 2.2.7 (stable).
    in "php.ini" file i have tried:
    extension=memcache.so
    and absolute path
    extension=/usr/local/lib/php/extensions/no-debug-non-zts-20121212/memcache.so
    In default php (inherit) works fine.
    When you put another version in a domain No errors anywhere, it simply is not present in phpinfo.
    Can you check it please?
     
  2. ribo

    ribo Well-Known Member

    Joined:
    Oct 15, 2015
    Messages:
    60
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    I checked it again. It s not the problem of inherit. It plays in php 5.5 but it s not plays in php 5.6
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,617
    Likes Received:
    1,787
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you verify if the expectation is that it works with both versions?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. ribo

    ribo Well-Known Member

    Joined:
    Oct 15, 2015
    Messages:
    60
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    No, it works only in php 5.5 but in php 5.6 or 5.4 is not work(is not show in phpinfo) with not any error. it s very strange. Note i have default php 5.5
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,617
    Likes Received:
    1,787
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Could you let us know the full steps we can take to reproduce the issue? Include information about which PHP handler you are using (e.g. if Mod_Ruid2 is enabled).

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. ribo

    ribo Well-Known Member

    Joined:
    Oct 15, 2015
    Messages:
    60
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    I use cgi-fcgi handler. I compiled memcache for centos. Mod ruid 2 is not enabled

    loaded modules
    Code:
    core_module (static)
    so_module (static)
    http_module (static)
    mpm_event_module (shared)
    cgid_module (shared)
    access_compat_module (shared)
    actions_module (shared)
    alias_module (shared)
    auth_basic_module (shared)
    authn_core_module (shared)
    authn_file_module (shared)
    authz_core_module (shared)
    authz_groupfile_module (shared)
    authz_host_module (shared)
    authz_user_module (shared)
    autoindex_module (shared)
    deflate_module (shared)
    dir_module (shared)
    expires_module (shared)
    filter_module (shared)
    headers_module (shared)
    include_module (shared)
    info_module (shared)
    log_config_module (shared)
    logio_module (shared)
    mime_module (shared)
    negotiation_module (shared)
    proxy_module (shared)
    proxy_fcgi_module (shared)
    proxy_http_module (shared)
    remoteip_module (shared)
    rewrite_module (shared)
    setenvif_module (shared)
    slotmem_shm_module (shared)
    socache_dbm_module (shared)
    socache_shmcb_module (shared)
    status_module (shared)
    suexec_module (shared)
    unique_id_module (shared)
    unixd_module (shared)
    userdir_module (shared)
    ssl_module (shared)
    security2_module (shared)
    suphp_module (shared)
    
     
    #6 ribo, Dec 16, 2015
    Last edited by a moderator: Dec 16, 2015
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,617
    Likes Received:
    1,787
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello :)

    Memcached is not yet supported in EasyApache 4. There's a similar thread at:

    EasyApache 4 Questions

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. ribo

    ribo Well-Known Member

    Joined:
    Oct 15, 2015
    Messages:
    60
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    I was revert back to easy apache 3 . Where can we see every time you make any improvements in easy apache 4 or you fix something?
     
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,617
    Likes Received:
    1,787
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. fisiculturismo

    fisiculturismo Registered

    Joined:
    Mar 13, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    brazil
    cPanel Access Level:
    Website Owner
    Will it be available in Cpanel v58?
     
  11. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,617
    Likes Received:
    1,787
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    There is no Memcache module available as an RPM in EasyApache 4. This is currently tracked with internal case EA-4642. I'll update this thread with more information as it becomes available. You can also track the progress of the following feature request:

    Plugin for per user memcached instance

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice