bigtomjp

Member
Apr 6, 2016
13
1
3
cPanel Access Level
Root Administrator
I am getting an error installing memcached at the last step of the PHP PECL module when configuring. PHP extension is already installed in EA4.

ERROR: `/root/tmp/pear/memcached/configure --with-php-config=/opt/cpanel/ea-php74/root/usr/bin/php-config --with-libmemcached-dir=no --with-zlib-dir=no --with-system-fastlz=no --enable-memcached-igbinary=no --enable-memcached-msgpack=no --enable-memcached-json=no --enable-memcached-protocol=no --enable-memcached-sasl=yes --enable-memcached-session=yes' failed

Any ideas? Most of the info on memcached with WHM is really old or links to old info. It may still be good, but it is old. No info on this error.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,257
313
Houston
You're right, the info is limited. This error is a configuration error and it's usually related to something right above this message you're posting. For example:
Code:
checking for libmemcached location... configure: error: memcached support requires libmemcached. Use --with-libmemcached-dir=
to specify the prefix where libmemcached headers and library are located
ERROR: `/root/tmp/pear/memcached/configure --with-php-config=/opt/cpanel/ea-php72/root/usr/bin/php-config --with-libmemcached-dir=no --with-zlib-dir=no --with-system-fastlz=no --enable-memcached-igbinary=no --enable-memcached-msgpack=no --enable-memcached-json=no --enable-memcached-protocol=no --enable-memcached-sasl=yes --enable-memcached-session=yes' failed
Can you show me the lines above that error?
 

bigtomjp

Member
Apr 6, 2016
13
1
3
cPanel Access Level
Root Administrator
@cPanelLauren This is a few lines just above the error:

Code:
checking whether to enable memcached protocol support... no
checking whether to use system FastLZ library... no
checking for ZLIB... yes, shared
checking for pkg-config... /bin/pkg-config
checking for zlib location... /usr
checking for session includes... /opt/cpanel/ea-php74/root/usr/include/php
checking for memcached session support... enabled
checking for memcached igbinary support... disabled
checking for memcached msgpack support... disabled
checking for libmemcached location... configure: error: memcached support requires libmemcached. Use --with-libmemcached-dir=
I did run
Code:
yum install libmemcached
and the install was successful.