The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Memory limit issue

Discussion in 'General Discussion' started by nicky_fashion, Jan 28, 2013.

  1. nicky_fashion

    nicky_fashion Registered

    Joined:
    Jan 28, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Dear cPanel/WHM community,

    I have a 12GB RAM VPS which is powered by WHM / cPanel. On this machine I mainly 2 medium large Magento stores as well as some small static websites. Recently though I am getting frustrated due to "Allowed memory size" errors. This is usually fixed (from my understanding) by increasing the "php_value memory_limit" in the related .htaccess file which I have set to a high value since the day I launched my store.

    In any case though I am recently getting the following errors in my error_log:

    PHP:
    PHP Fatal error:  Allowed memory size of 52428800 bytes exhausted (tried to allocate 10282 bytesin /home/store/public_html/includes/src/__default.php on line 2976

    PHP Fatal error
    :  Allowed memory size of 52428800 bytes exhausted (tried to allocate 32 bytesin /home/store/public_html/includes/src/__default.php on line 56485

    PHP Fatal error
    :  Allowed memory size of 52428800 bytes exhausted (tried to allocate 77 bytesin /home/store/public_html/includes/src/__default.php on line 56485
    I know that this now is not directly related to cPanel but what seems strange to me here is the "52428800 bytes" message which from my understanding translate to 50MB. Where could these 50MB be predefined?

    I've tried several things hereby. A php info script shows the CORE memory_limit at the value I prefefined in WHM, I've seen to apply related changes to my stores .htaccess file and try to add a ini_set option in my index.php however I am still getting "Allowed memory size of 52428800 bytes exhausted" errors.

    Are there any possibilities that there is some sort of limit being set from my current configuration? Could this have something to do with nginx, suhosin, memcached, zendguard or ioncube? I've seen to post this in several related forums but I haven't gotten any answer yet that could help me resolve the issue at hand.

    Hardware setup:

    • VPS with 12GB RAM
    • WHM / cPanel
    • NginxCP
    Current PHP configuration:

    • Default PHP Version (.php files) 5
    • PHP 5 Handler dso
    • PHP 4 Handler none
    • Apache suEXEC on
    • Apache Ruid2 on
    My Magento setup:

    • Magento 1.5.10
    • Memcache enabled
    • Compilation enabled

    It would be deeply appreciated if someone is able to help me with this issue. Thank you very much.
     
    #1 nicky_fashion, Jan 28, 2013
    Last edited: Jan 29, 2013
  2. Kailash1

    Kailash1 Well-Known Member

    Joined:
    Nov 27, 2006
    Messages:
    252
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
    You can increase this limit from global php.ini file:

    /usr/local/lib/php.ini

    Just increase PHP memory from the above file and restart Apache.

    Kailash
     
  3. nicky_fashion

    nicky_fashion Registered

    Joined:
    Jan 28, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thank you very much for your reply. The /usr/local/lib/php.ini file shows the exact amount of ram I have attributed from within WHM. I think the limit must be elsewhere.
     
  4. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    In that cPanel you should have a "PHP-Info" link.
    Click that link and see what is the value of:
    "Loaded Configuration File"
    and also:
    "additional .ini files parsed"
     
Loading...

Share This Page