The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Memory Usage Restrictions

Discussion in 'General Discussion' started by postcd, Feb 11, 2012.

  1. postcd

    postcd Well-Known Member

    Joined:
    Oct 22, 2010
    Messages:
    621
    Likes Received:
    6
    Trophy Points:
    18
    Hello i ran this WHM tool believing it will give me any options to confirm any changes, but it didnt

    Result: Largest Webserver child cgi/ssi/php is now limited to 2040 meg

    After this, i deleted xcache.so and memcached.so from WHM PHP Editor, and im also manipulated with "mysql.connect_timeout" value, after Apache restart i noticed that my Wordpress blogs ocassionally do not show content of Categories, like the mysql query is too big. And my /dev/loop0 is 100% full all time, mysql restart dont help.

    I changed "mysql.connect_timeout" back and restarted again. But this Wordpress error is still there and /dev/loop0 is still full.

    Please what happend? Can be Memory Usage Restrictions cause?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The "WHM >> Service Configuration >> Apache Configuration >> Memory Usage Restrictions" option simply adds the following entries to the Apache configuration file:

    Code:
    RLimitMEM XXX
    RLimitCPU XXX
    The exact values used depend on the usage history. As far as this effecting your WordPress application, you will need to check the Apache error log. You can monitor the Apache error log via the following command:

    Code:
    # tail -f /usr/local/apache/logs/error_log
    Look for the output when your website encounters the problem. Alternatively, you can search the Apache error log for the account username to see which error messages have occurred thus far. EX:

    Code:
    # grep username /usr/local/apache/logs/error_log
    Thank you.
     
  3. postcd

    postcd Well-Known Member

    Joined:
    Oct 22, 2010
    Messages:
    621
    Likes Received:
    6
    Trophy Points:
    18
    Thank You for the helpfull reply. I think the cause of full /tmp was temporarily enabled eAccelerator. Now the loop0 is ok.

    The output of above command is alot of:

     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  5. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Is xcache possibly filling up /tmp in this instance? Removing the xcache.so file wouldn't remove any already existing files in /tmp directory. Check the size of the directory:

    Code:
    du -sh /tmp/xcache
    Also, what is the size of /tmp folder?

    Code:
    df -kh | grep /tmp
     
Loading...

Share This Page