The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Merged - cpanel loading EXTREME SLOW

Discussion in 'General Discussion' started by jandafields, Jan 31, 2005.

  1. jandafields

    jandafields Well-Known Member

    Joined:
    May 6, 2004
    Messages:
    426
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    cpanel loading EXTREME SLOW

    when I go to domain.com/cpanel, it asks for user : pass

    Then, it takes several minutes to get to the menu.

    CPU Load is very low. Everything else is very fast (WHM, websites)

    This happened after I installed suexec and phpsuexec.

    When I finally get into cpanel, everything works fast EXCEPT:

    FTP -> MANAGE ACCOUNTS is very very very slow...
     
  2. jandafields

    jandafields Well-Known Member

    Joined:
    May 6, 2004
    Messages:
    426
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    I fixed this for the second time now by using upcp. I wish I knew what upcp does to fix this problem. It is probably one little thing wrong somewhere. I don't like using upcp for this, because it overrights all my custom stuff. Anyway, we are going fast again...
     
  3. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    See if service cpanel restart does anything for the speed.
     
  4. ike00

    ike00 Registered

    Joined:
    Jul 18, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I'm having this exact issue. It seems to have happened after installing Postgresql today. Neither upcp nor restarting cpanel have fixed the issue.

    I'm running Pureftpd. Logging in via FTP and transferring files works fine, no issues there...only issues with cpanel.
     
  5. ike00

    ike00 Registered

    Joined:
    Jul 18, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I managed to fix this issue. I disabled anonymous FTP, and then re-enabled it. Amazingly, everything is back to normal :confused: Oh well!
     
  6. jandafields

    jandafields Well-Known Member

    Joined:
    May 6, 2004
    Messages:
    426
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    No, that does not help this issue. I did not try the Anon-FTP tip, although I had tried switching from ProFTP -> PureFTP and back to ProFTP with no success. But, as stated above upcp did the trick. I just wanted to find out what upcp did to fix it.
     
  7. ezztro

    ezztro Well-Known Member

    Joined:
    Nov 11, 2003
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Same Prob here.

    CPU Load OK.
    WHM very Fast
    Website very fast
    cpanel very SLOW. Needs up to 45 Seconds to load.

    WHM 10.0.0 cPanel 10.0.0-R7
    RedHat 9 i686 - WHM X v3.1.0
     
  8. destr0yr

    destr0yr Well-Known Member

    Joined:
    May 4, 2004
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Kelowna, BC.
    check your /etc/resolv.conf.. make sure your nameserver entries are correct and remove any entries for localhost or 127.0.0.1
     
  9. ezztro

    ezztro Well-Known Member

    Joined:
    Nov 11, 2003
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    All entries at resolv.conf are correct.
    No entries for 127.0.0.1 and localhost
     
  10. jandafields

    jandafields Well-Known Member

    Joined:
    May 6, 2004
    Messages:
    426
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Please try enabling / disabling (back and forth) anonmyous FTP a few times from root WHM. Then restart cpanel. Please let me know what the result is, I am very curious.
     
  11. ezztro

    ezztro Well-Known Member

    Joined:
    Nov 11, 2003
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    same Prob :(
     
  12. jandafields

    jandafields Well-Known Member

    Joined:
    May 6, 2004
    Messages:
    426
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    /scripts/upcp --force has so far always fixed it for me.
     
  13. Toby

    Toby Member

    Joined:
    Jul 14, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Toggling Anon FTP (off and then on again)

    Did it for me.

    FYI I just added POSTgres yesterday and installed PHP 5.0.3 as well. :eek:

    Toby
     
  14. DigiCrime

    DigiCrime Well-Known Member

    Joined:
    Nov 27, 2002
    Messages:
    399
    Likes Received:
    0
    Trophy Points:
    16
    I contacted Cpanel earlier today about this

    Look for a lock file ls -l /usr/local/apache/conf/httpd*

    delete the lock file, restart everything
     
  15. ezztro

    ezztro Well-Known Member

    Joined:
    Nov 11, 2003
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    There is no lock file
     
  16. aodat2

    aodat2 Registered

    Joined:
    Sep 7, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Slowness!!!

    My cPanel seems to be running at Turtle speed!!! It seems that everything that I do could not change this. I have the auto updater on and everything seems to be working fine until a few hours ago.

    cPanel seems to be dead or something. I tried accessing WHM and it runs at perfect speed as for cPanel, it just takes forever to load. :mad:

    Did anyone experience this? Does anyone know how to solve this problem? Has anyone came over such a thing before?

    I seriously need big time help. :(

    Thanx.
     
  17. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    Threads merged -

    Threads merged to cut down on duplicate issues.
     
  18. tm1000

    tm1000 Registered

    Joined:
    Jun 29, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1

    This worked perfectly for me! I also did the turn on/off Anon Access a few times before running this and now cpanel loads much faster! thank you!

    /scripts/upcp --force
    service cpanel restart
     
  19. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    check to make sure /usr/local/apache/conf/httpd.conf.lock is not there.

    Also check the size of your httpd.conf
     
  20. xvihost

    xvihost Active Member

    Joined:
    Sep 8, 2005
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    I am having this extremely slow loading cPanel problem, but I think for a different reason.

    My cpanel error_log shows these when cPanel is finally near completion:

    I am backing up to an NFS mount and I believe cPanel is trying to get the space used on the mount to attribute it towards the user's quota.

    Is there a way I can tell cPanel to ignore a path? (Specifically /mnt/backup ?)

    Peace and thanks,
    Tom
     
Loading...

Share This Page