Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

message size exceeds

Discussion in 'E-mail Discussion' started by teknom, Mar 24, 2018.

  1. teknom

    teknom Member

    Joined:
    May 20, 2016
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Turkey
    cPanel Access Level:
    Root Administrator
    hello there, i want to increase message size limit value. i guess its now 20mb limited. i searched message_size_limit parameter on exim configuration manager > advanged editor section but nothing founded. also dig /etc/exim.conf file but message_size_limit this parameter not seen :)

    i did not remember to delete this parameter but i remember i made some modifications on exim.conf file. really i dont remember what i did before :)
    is there any parameter checks attached files sizes?
    if i add message_size_limit parameter on additional configuration settings section, does it resolve?
     
  2. rpvw

    rpvw Well-Known Member

    Joined:
    Jul 18, 2013
    Messages:
    670
    Likes Received:
    224
    Trophy Points:
    43
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    I believe that cPanel defaults to 50MB for email message size if you don't define anything else.

    I am not clever enough to be able to tell you what to look for if you added the message_size_limit parameter anywhere else other than in the WHM Exim Configuration Manager, but here are the instructions that might jog your memory.

    1) Go to your Advanced Editor in the Exim Configuration Manager and scroll down until you get to the blue "Add additional configuration settings" button and click on the button.

    2) As soon as you click on the button, immediately above it will appear a drop-down which contains an option message_size_limit which will display the Exim Default: 50M after you select it.

    3) Enter the new value you want (Don't forget to scroll to the bottom and SAVE after editing)

    >>OR<<

    1) Search the Advanced Editor in the Exim Configuration Manager screen for the message_size_limit parameter you may have set previously, and edit the value as necessary (Don't forget to scroll to the bottom and SAVE after editing)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. teknom

    teknom Member

    Joined:
    May 20, 2016
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Turkey
    cPanel Access Level:
    Root Administrator
    as i sait there is no message_size_limit parameter on exim.conf file :) i cant find this value i looked advanged settings sections on panel and conf file.
     
  4. rpvw

    rpvw Well-Known Member

    Joined:
    Jul 18, 2013
    Messages:
    670
    Likes Received:
    224
    Trophy Points:
    43
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    If you have no size limits set anywhere, you probably default to 50M (Exim Default)

    Check in a terminal with
    Code:
    exim -bP | grep message_size_limit
    It will return message_size_limit = 50M if nothing has been set to override it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #4 rpvw, Mar 24, 2018
    Last edited: Mar 24, 2018
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,711
    Likes Received:
    1,791
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    You have to add it as a new value:

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. keat63

    keat63 Well-Known Member

    Joined:
    Nov 20, 2014
    Messages:
    981
    Likes Received:
    41
    Trophy Points:
    28
    cPanel Access Level:
    Root Administrator
    Wouldn't this be dependant on the recieving server ?
    Whilst you may be able to send a 50mb email, the recieving server may not be able to receive it. ??
     
  7. teknom

    teknom Member

    Joined:
    May 20, 2016
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Turkey
    cPanel Access Level:
    Root Administrator
    exim -bP | grep message_size_limit output:
    message_size_limit = 50M
    but something block outgoing attached files above 20m
    does it possible block by clamd?
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,711
    Likes Received:
    1,791
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Can you verify the output you see in /var/log/exim_mainlog when the message delivery attempt fails? EX:

    Code:
    exigrep "MSGSUBJECT" /var/log/exim_mainlog
    Replace MSGSUBJECT with the subject of the test message.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice