Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

messages are stuck for a long time in mail queue

Discussion in 'E-mail Discussion' started by dxer, Jul 17, 2004.

  1. dxer

    dxer Well-Known Member

    Joined:
    Sep 9, 2002
    Messages:
    301
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Europe
    Clients of mine are reporting that sent mails are sometimes not delivered immediately but sometimes in about 30-60 minutes from the time they are sent.

    When a client reports this I check WHM/MailQueue and I see message is there but i don't know what is waiting there. How can i fix this so messages will be sent immediatelly ?

    Thanks
     
  2. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    773
    Likes Received:
    4
    Trophy Points:
    318
    Location:
    N.W. Iowa
    if you recently updated exim, look in the exim.conf, toward the top, you see this setting:
    queue_only = true
    comment it out, restart exim.

    we had the same problems, plus if your running MailScanner, this slows things down too.

    Mickalo
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    It is important to know if you are or used to run MailScanner, as mickalo pointed out. One issues that can cause problems, if you are running MailScanner, is if you use a lot of catchall aliases and are also prone to email dictionary attacks.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. dxer

    dxer Well-Known Member

    Joined:
    Sep 9, 2002
    Messages:
    301
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Europe
    I used to run Mailscanner but Mailscanner is disabled for sometime now.

    But why you wrote that this can be cause of "used to run mailscanner" ? What could I do to fix this. is mailscanner caused some kind of change somewhere in exim and what change ?
     
  5. dxer

    dxer Well-Known Member

    Joined:
    Sep 9, 2002
    Messages:
    301
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Europe
    There is no "queue_only" in my exim.conf so there must be some other thing to try....
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice