migirate to EA_4 error “Cpanel::Easy::Apache::Ident” ignored since it does not have an RPM

RIkaweb

Registered
Sep 11, 2017
3
0
1
Montreal
cPanel Access Level
Root Administrator
Hi
I got this eror when I run cpanel migirate to EA_4 script

Code:
checkyum version 22.3
[2018-12-12 11:48:04 -0500] info [migrate_ea3_to_ea4] Setting the system default PHP version to v5.6 using the Apache 'suphp' handler.
[2018-12-12 11:48:04 -0500] info [migrate_ea3_to_ea4]
EasyApache 4 Installing preliminary tools.
[2018-12-12 11:48:04 -0500] info [migrate_ea3_to_ea4]
EasyApache 4 converted your EasyApache 3 profile, with warnings.

[2018-12-12 11:48:04 -0500] info [migrate_ea3_to_ea4] Adding the missing package, ea-apache24-mod_suexec, to the EasyApache 4 profile.
[2018-12-12 11:48:04 -0500] info [migrate_ea3_to_ea4] Current profile has the following MPMs: ea-apache24-mod_mpm_prefork
[2018-12-12 11:48:04 -0500] info [migrate_ea3_to_ea4] “Cpanel::Easy::Apache::Access” ignored since it does not have an RPM.
[2018-12-12 11:48:04 -0500] info [migrate_ea3_to_ea4] “Cpanel::Easy::Apache::Ident” ignored since it does not have an RPM.
[2018-12-12 11:48:04 -0500] info [migrate_ea3_to_ea4] Something is wrong
[2018-12-12 11:48:04 -0500] info [migrate_ea3_to_ea4] EasyApache 4 was unable to convert your EasyApache 3 profile, with these fatal errors.
[2018-12-12 11:48:04 -0500] info [migrate_ea3_to_ea4] [1;33mIn cPanel & WHM version 76 and earlier, the FCGId module does not handle PHP inheritance correctly. We fixed this issue in cPanel & WHM version 78. For more information, read https://go.cpanel.net/EA4FCGId[0m
A record of this process may be found at : /var/cpanel/updatelogs/ea4_migration.1544633283.log
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,213
363
Hello @RIkaweb,

[2018-12-12 11:48:04 -0500] info [migrate_ea3_to_ea4] “Cpanel::Easy::Apache::Access” ignored since it does not have an RPM. [2018-12-12 11:48:04 -0500] info [migrate_ea3_to_ea4] “Cpanel::Easy::Apache::Ident” ignored since it does not have an RPM.
These are warning messages to inform you that a particular option enabled in your EA3 profile has no direct EA4 RPM equivalent. This shouldn't result in any issues post-migration unless you have specifically configured custom configuration values for these modules. In the case of Mod_Access, it's deprecated in Apache 2.4. Thus, it's not included with EasyApache 4 and the following comparable modules are compiled with Apache instead:

Code:
mod_access_compat.so
mod_auth_basic.so
mod_authn_core.so
mod_authn_file.so
mod_authz_core.so
mod_authz_groupfile.so
mod_authz_host.so
mod_authz_user.so
[2018-12-12 11:48:04 -0500] info [migrate_ea3_to_ea4] EasyApache 4 was unable to convert your EasyApache 3 profile, with these fatal errors. [2018-12-12 11:48:04 -0500] info [migrate_ea3_to_ea4] [1;33mIn cPanel & WHM version 76 and earlier, the FCGId module does not handle PHP inheritance correctly. We fixed this issue in cPanel & WHM version 78. For more information, read Apache Module: FCGId - EasyApache 4 - cPanel Documentation
You'll need to install the EasyApache 4 experimental repo prior to upgrading to EA4 if you'd like to continue using mod_fcgid as the PHP handler on the system. You can read more about this at:

Apache Module: FCGId - EasyApache 4 - cPanel Documentation

If you'd like to use the FCGId experimental RPM with EasyApache 4, you can install the experiential repo using the following command:

Code:
yum install ea4-experimental
Then, attempt to convert to EA4 again.

Thanks!