Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Migration Failed - Package Conflicts

Discussion in 'CloudLinux' started by SteveK, Jan 2, 2019.

  1. SteveK

    SteveK Member

    Joined:
    Apr 21, 2016
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Canada
    cPanel Access Level:
    DataCenter Provider
    I ran preflight checks, most errors it mentioned were nothing that would impact me. I ran the migration tool and everything came back green. However it did not switch to EA4. I realized later that it said it worked but when you looked at the logs it actually did fail.

    So since I'm running cloudlinux 6 I ran the script manually

    Code:
    cd ~; wget https://repo.cloudlinux.com/cloudlinux/sources/cloudlinux_ea3_to_ea4; sh cloudlinux_ea3_to_ea4 --convert
    
    It said it was going to update a bunch of packages but ended up spitting out this: (truncated as you'll get the idea)
    Code:
    Transaction Check Error:
      file /etc/bash_completion.d/git from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package git-cpane
    l-1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/bin/git from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package git-cpanel-1.8.3.1-1.el
    6.cloudlinux.x86_64
      file /usr/libexec/git-core/git from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package git-cpanel
    -1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/bin/git-receive-pack from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package git-cpanel
    -1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/libexec/git-core/git-receive-pack from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from packa
    ge git-cpanel-1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/bin/git-shell from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package git-cpanel-1.8.3.
    1-1.el6.cloudlinux.x86_64
      file /usr/libexec/git-core/git-shell from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package git-
    cpanel-1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/bin/git-upload-archive from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package git-cpan
    el-1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/libexec/git-core/git-upload-archive from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from pac
    kage git-cpanel-1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/bin/git-upload-pack from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package git-cpanel-
    1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/libexec/git-core/git-upload-pack from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from packag
    e git-cpanel-1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/libexec/git-core/git-add from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package git-cp
    anel-1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/libexec/git-core/git-add--interactive from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from p
    ackage git-cpanel-1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/libexec/git-core/git-am from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package git-cpa
    nel-1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/libexec/git-core/git-annotate from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package g
    it-cpanel-1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/libexec/git-core/git-apply from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package git-
    cpanel-1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/libexec/git-core/git-archive from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package gi
    t-cpanel-1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/libexec/git-core/git-bisect from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package git
    -cpanel-1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/libexec/git-core/git-bisect--helper from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from pac
    kage git-cpanel-1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/libexec/git-core/git-blame from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package git-
    cpanel-1.8.3.1-1.el6.cloudlinux.x86_64
    
    
    Any idea how to fix this?
     
    #1 SteveK, Jan 2, 2019
    Last edited by a moderator: Jan 3, 2019
  2. Infopro

    Infopro cPanel Sr. Product Evangelist Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,826
    Likes Received:
    476
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. SteveK

    SteveK Member

    Joined:
    Apr 21, 2016
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Canada
    cPanel Access Level:
    DataCenter Provider
    No they didn't help. Neither article. Thanks though. I may need to call into support for this one.
     
  4. SteveK

    SteveK Member

    Joined:
    Apr 21, 2016
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Canada
    cPanel Access Level:
    DataCenter Provider
    More info

    Code:
     yum install perl-Git --disableexcludes=main
    Loaded plugins: fastestmirror, rhnplugin, security
    Setting up Install Process
    Loading mirror speeds from cached hostfile
     * cpanel-addons-production-feed: 198.245.49.52
     * cloudlinux-x86_64-server-6: xmlrpc.cln.cloudlinux.com
     * epel: ftp.cse.buffalo.edu
    Resolving Dependencies
    --> Running transaction check
    ---> Package perl-Git.noarch 0:1.7.1-9.el6_9 will be installed
    --> Processing Dependency: git = 1.7.1-9.el6_9 for package: perl-Git-1.7.1-9.el6_9.noarch
    --> Processing Dependency: perl(Error) for package: perl-Git-1.7.1-9.el6_9.noarch
    --> Processing Dependency: perl(Error) for package: perl-Git-1.7.1-9.el6_9.noarch
    --> Running transaction check
    ---> Package git.x86_64 0:1.7.1-9.el6_9 will be installed
    ---> Package perl-Error.noarch 1:0.17015-4.el6 will be installed
    --> Finished Dependency Resolution
    
    Dependencies Resolved
    
    ==============================================================================================================================================================================================================================================
     Package                                              Arch                                             Version                                                     Repository                                                            Size
    ==============================================================================================================================================================================================================================================
    Installing:
     perl-Git                                             noarch                                           1.7.1-9.el6_9                                               cloudlinux-x86_64-server-6                                            28 k
    Installing for dependencies:
     git                                                  x86_64                                           1.7.1-9.el6_9                                               cloudlinux-x86_64-server-6                                           4.6 M
     perl-Error                                           noarch                                           1:0.17015-4.el6                                             cloudlinux-x86_64-server-6                                            28 k
    
    Transaction Summary
    ==============================================================================================================================================================================================================================================
    Install       3 Package(s)
    
    Total size: 4.7 M
    Installed size: 15 M
    Is this ok [y/N]: y
    Downloading Packages:
    Running rpm_check_debug
    Running Transaction Test
    
    
    Transaction Check Error:
      file /etc/bash_completion.d/git from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package git-cpanel-1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/bin/git from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package git-cpanel-1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/libexec/git-core/git from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package git-cpanel-1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/bin/git-receive-pack from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package git-cpanel-1.8.3.1-1.el6.cloudlinux.x86_64
      file /usr/libexec/git-core/git-receive-pack from install of git-1.7.1-9.el6_9.x86_64 conflicts with file from package git-cpanel-1.8.3.1-1.el6.cloudlinux.x86_64
    
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice