Migration path from API1 after cPanel upgrade to 11.36

varr

Registered
May 6, 2013
1
0
1
cPanel Access Level
Root Administrator
So we recently upgraded our server to cPanel 11.36 from a prior version and as it turns out it rendered all of our API1 calls obsolete and useless.

We've been using David Neimeyer's API libraries from 2011 which were working great up to this point.

Are there any recommendations for an easy migration/upgrade path to a usable API now that API1 is deprecated that works as well as David's PHP library?
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,578
52
308
cPanel Access Level
Root Administrator
So we recently upgraded our server to cPanel 11.36 from a prior version and as it turns out it rendered all of our API1 calls obsolete and useless.

We've been using David Neimeyer's API libraries from 2011 which were working great up to this point.

Are there any recommendations for an easy migration/upgrade path to a usable API now that API1 is deprecated that works as well as David's PHP library?
Please ensure your system is using the latest release of 11.36.1. There were some bugs related to LivePHP that are fixed in the latest 11.36.1 release.