The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ming error installing fp-5.0

Discussion in 'General Discussion' started by analog, Aug 16, 2001.

  1. analog

    analog Member

    Joined:
    Aug 13, 2001
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I am trying to install the fp 2002 extensions, and am getting the following error:

    checking whether to include ming support... yes
    checking for Ming_setScale in -lming... no
    configure: error: Ming library 0.1.0 or greater required.

    I downloaded Ming, but there doesn\'t appear to be a way to install it so that the upgrade script knows where it is.

    I tried the static module, and copying the libraries to the dir I am installing from. No go.

    Any ideas?

    Thanks.
     
  2. analog

    analog Member

    Joined:
    Aug 13, 2001
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Anyone??? Pleeeaaasseee!!
     
  3. Karl

    Karl Well-Known Member
    PartnerNOC

    Joined:
    Aug 10, 2001
    Messages:
    84
    Likes Received:
    1
    Trophy Points:
    8
    Download the ming source, then go into the dir you extracted to and type:

    make && make install

    and you should be set.
     
  4. analog

    analog Member

    Joined:
    Aug 13, 2001
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I guess I should have been more clear in my previous post. I actually already did that.

    Thanks.
     
  5. Mark Vockler

    Mark Vockler Active Member

    Joined:
    Aug 10, 2001
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Try installing buildapache.sea first, then followed by the fp-5.0 upgrade.

    Mark
     
  6. Brad

    Brad Well-Known Member

    Joined:
    Aug 16, 2001
    Messages:
    231
    Likes Received:
    0
    Trophy Points:
    16
    Look to see where your extension directory is for Php and copy it there. Type php-config --extension-dir ..

    If the path you get above is not what is shown in your php.ini file for your extension_dir , then this is usually the cause.





    [quote:ac63521bc3]I am trying to install the fp 2002 extensions, and am getting the following error:

    checking whether to include ming support... yes
    checking for Ming_setScale in -lming... no
    configure: error: Ming library 0.1.0 or greater required.

    I downloaded Ming, but there doesn\'t appear to be a way to install it so that the upgrade script knows where it is.

    I tried the static module, and copying the libraries to the dir I am installing from. No go.

    Any ideas?

    Thanks. [/quote:ac63521bc3]
     
  7. analog

    analog Member

    Joined:
    Aug 13, 2001
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Brad,

    I checked that setting, and sure enough, they did not match... fixed php.ini, and tried again.. same exact error when it was compiling PHP.

    Mark, tried buildapache first, and it failed on the exact same error when it tried to compile php, so I didn\'t even try the fp-upgrade.

    Can I just disable this Ming? I don\'t need it.

    Thanks.
     
  8. analog

    analog Member

    Joined:
    Aug 13, 2001
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Maybe I should submit this as a bug report?
     
Loading...

Share This Page