The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Missing Fantastico Link in New Edge

Discussion in 'General Discussion' started by DIYHosting, Jul 17, 2005.

  1. DIYHosting

    DIYHosting Well-Known Member

    Joined:
    Nov 27, 2003
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Saskatoon, SK, Canada
    Just noticed that the Fantastico link is no longer showing in the new edge builds (10.4.0-E105).
     
  2. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    You will want to either contact the vendor of the software ( fantastico ) or submit a bug report to cpanel ( bugzilla.cpanel.net ).

    Using edge, you should expect such issues, and you should be aware of and actively using the bugzilla report system. Thats how bugs get resolved :)

    I keep pestering the developers to hire psychics but, I too have not submitted a bugzilla request so thats my fault!
     
  3. challii

    challii Well-Known Member

    Joined:
    Feb 3, 2004
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    6
  4. kebirhost

    kebirhost Member

    Joined:
    Jan 9, 2005
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    A Suggestion

    Hello,

    I had the same problem but I changed the theme of cpanel from x to Xcontroller, the issue is fixed. You may try..

    Thanks

    Melih
     
  5. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    cp /usr/local/cpanel/3rdparty/fantastico/xskin.html /usr/local/cpanel/base/frontend/x/cells/fantastico.html
     
  6. kosmo

    kosmo Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    403
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    All over Europe
    There will be an updated installer on Monday July 18th, which will perform the necessary changes:

    mv /usr/local/cpanel/3rdparty/fantastico/xskin.html /usr/local/cpanel/base/frontend/x/cells/fantastico.html

    If you do cp instead of mv, you will get duplicate Fantastico icons.

    kosmo
     
  7. DIYHosting

    DIYHosting Well-Known Member

    Joined:
    Nov 27, 2003
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Saskatoon, SK, Canada
    I just pasted the missing code back in x themes index.html file from an older version and it worked. The fantastico link section was missing entirely.
     
  8. xWho

    xWho Well-Known Member

    Joined:
    Apr 23, 2003
    Messages:
    112
    Likes Received:
    0
    Trophy Points:
    16
    Will the new installer on the 18th address the permission problems plagueing edge installations?
     
  9. kosmo

    kosmo Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    403
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    All over Europe
    DIYHosting,

    this is the wrong way to fix things. The next CPanel update will replace your code.
    The "mv" command is the best way and it will be the official way how things will be done in the future.


    xWho,

    the installer is not related to this, there will be a new Fantastico release which will make use of the new cpanel tags to address the httpd.conf issue. The new Fantastico release will be Monday or the latest Tuesday. We are working on it.


    kosmo
     
  10. DIYHosting

    DIYHosting Well-Known Member

    Joined:
    Nov 27, 2003
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Saskatoon, SK, Canada
    Yeah I see now that the are moving for 3rd party apps to be placed in the cells directory. I have run the command you listed above. Thanks!
     
  11. BianchiDude

    BianchiDude Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2005
    Messages:
    619
    Likes Received:
    0
    Trophy Points:
    16
    I am also missing the fantastico Icon after updating cpanel.

    I ran the command above and still dont get the fantastic icon.

    What gives?
     
    #11 BianchiDude, Jul 18, 2005
    Last edited: Jul 18, 2005
  12. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    Same problem with same build version here ....

    Funny thing is it appears that only "X" themes are effected.

    Fantastico still shows up and works properly on all other themes
     
  13. BianchiDude

    BianchiDude Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2005
    Messages:
    619
    Likes Received:
    0
    Trophy Points:
    16
  14. kosmo

    kosmo Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    403
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    All over Europe
    If you still have problems:
    - Did you get an error message when entering the mv command?

    - What is displayed when you enter:
    ls -al /usr/local/cpanel/base/frontend/x/cells

    - Make sure you enable Fantastico in WHM -> Packages (Features Lists)

    kosmo
     
  15. thehostinghut

    thehostinghut Well-Known Member

    Joined:
    Jan 5, 2005
    Messages:
    232
    Likes Received:
    0
    Trophy Points:
    16
    Also if the links are not in your cpanel make sure you are runnig the x theme and not the x2 theme. I thought it was not working until I changed all my clients to the x theme.

    Tracy
     
  16. BianchiDude

    BianchiDude Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2005
    Messages:
    619
    Likes Received:
    0
    Trophy Points:
    16
    If you still have problems:
    - Did you get an error message when entering the mv command?
    >>Yes
    root@server1 [/usr/local/cpanel/3rdparty/fantastico]# mv /usr/local/cpanel/3rdparty/fantastico/xskin.html /usr/local/cpanel/base/frontend/x/cells/fantastico.html

    mv: cannot move `/usr/local/cpanel/3rdparty/fantastico/xskin.html' to `/usr/local/cpanel/base/frontend/x/cells/fantastico.html': No such file or directory


    - What is displayed when you enter:
    ls -al /usr/local/cpanel/base/frontend/x/cells
    >>
    root@server1 [/usr/local/cpanel/3rdparty/fantastico]# ls -al /usr/local/cpanel/base/frontend/x/cells
    /bin/ls: /usr/local/cpanel/base/frontend/x/cells: No such file or directory

    - Make sure you enable Fantastico in WHM -> Packages (Features Lists)
    >>It is
     
  17. kosmo

    kosmo Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    403
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    All over Europe
    Do this:

    mkdir /usr/local/cpanel/base/frontend/x/cells

    mv /usr/local/cpanel/3rdparty/fantastico/xskin.html /usr/local/cpanel/base/frontend/x/cells/fantastico.html

    ln -s /usr/local/cpanel/base/frontend/x/cells /usr/local/cpanel/base/frontend/x2/cells

    kosmo
     
  18. UndeaD

    UndeaD Well-Known Member

    Joined:
    Apr 16, 2005
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    root@server [/]# ln -s /usr/local/cpanel/3rdparty/fantastico /usr/local/cpanel/base/frontend/x
    ln: `/usr/local/cpanel/base/frontend/x/fantastico': File exists
    root@server [/]#


    errror ?
     
  19. kosmo

    kosmo Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    403
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    All over Europe
    Why exactly are you trying this command?
     
  20. shivinvijai

    shivinvijai Member

    Joined:
    Mar 1, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Fantastico Icon missing

    Hello,

    I also have the same issue. Fantastico icon was missing from my clients cpanel.

    I seems to be an issue with the new version of whm/cpanel (WHM 11.2.0 cPanel 11.6.0-C14666). Please have a look into the steps which helps to solve this issue.

    Login to WHM
    Select Update Config
    Change cPanel/WHM Updates to utomatic (STABLE tree)
    Save
    Login to shell
    /scripts/upcp --force

    Then when i login to my clients cpanel, i got the Fantastico Icon

    Thanks,
     
Loading...

Share This Page