The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

missing icons in apache

Discussion in 'EasyApache' started by quadrahost, Mar 11, 2004.

  1. quadrahost

    quadrahost Active Member

    Joined:
    Jul 17, 2003
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    ever since I got this box, the icons have been missing when I go to a directory via http. I've now got some customers complaining after 9 months, so I need to get it fixed.

    Anyone know how to take care of the problem?


    Example - http://www.nefariousdime.com/ot/
     
  2. LordJMann

    LordJMann Well-Known Member

    Joined:
    Jun 15, 2003
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
  3. quadrahost

    quadrahost Active Member

    Joined:
    Jul 17, 2003
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    thanks, but that doesn't solve the problem.
     
  4. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Set the servername directive in httpd.conf. Right click the images and you will see that it is calling the wrong path.
     
  5. quadrahost

    quadrahost Active Member

    Joined:
    Jul 17, 2003
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    it is set as

    Alias //icons/ "//usr/local/apache/icons/"

    <Directory "//usr/local/apache/icons/">
    Options Indexes Multiviews
    AllowOverride None
    Order alloy,deny
    Allow from all
    </Directory>



    That looks correct to me :confused:
     
  6. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    That looks correct to you?
    You have two slashes. It should be

    Code:
    Alias /icons/ "/usr/local/apache/icons/"
    
    <Directory "/usr/local/apache/icons/">
    Options Indexes Multiviews
    AllowOverride None
    Order alloy,deny
    Allow from all
    </Directory>
    Also, as I mentioned before, do you have the ServerName set?

    Code:
    #
    # ServerName allows you to set a host name which is sent back to clients for
    # your server if it's different than the one the program would get (i.e., use
    # "www" instead of the host's real name).
    # 
    # Note: You cannot just invent host names and hope they work. The name you
    # define here must be a valid DNS name for your host. If you don't understand
    # this, ask your network administrator.
    # If your host doesn't have a registered DNS name, enter its IP address here.
    # You will have to access it by its address (e.g., [url]http://123.45.67.89/[/url])   
    # anyway, and this will make redirections work in a sensible way.   
    # 
    # 127.0.0.1 is the TCP/IP local loop-back address, often named localhost. Your
    # machine always knows itself by this address. If you use Apache strictly for
    # local testing and development, you may use 127.0.0.1 as the server name.
    #
    ServerName server.domain.com
     
  7. quadrahost

    quadrahost Active Member

    Joined:
    Jul 17, 2003
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    the // is how it was default set. I changed to a single / and removed the # before the ServerName entry which is plain.rackshack.net

    After a reboot, I still have no icons.
     
  8. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    The servername should be your servername, not rackshack.net.
    You changed all 3 of the double slashes?
    No reboot is necessary. Just restart apache.
     
  9. quadrahost

    quadrahost Active Member

    Joined:
    Jul 17, 2003
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    thanks casey, got it working. All the icons had // before them as well in httpd.conf. After removing one slash from each icon, everything worked.
     
Loading...

Share This Page