The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Missing RPMS on upcp

Discussion in 'General Discussion' started by bear, Aug 25, 2013.

  1. bear

    bear Well-Known Member

    Joined:
    Sep 24, 2002
    Messages:
    113
    Likes Received:
    1
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Recently upgraded an OS on a test box to CentOS 5.9, and after doing so wanted to run upcp to get the latest version. I can only get to 11.34.2, as anything above that fails with this error:
    Code:
    E Sysup: Needed system RPMs were not installed: cairo, lcms, libX11-devel, libXpm, libXpm-devel, libtool-ltdl, libtool-ltdl-devel
    Really not sure where to go from that, since looking for these RPMs has at least some of them simply not seeming to exist. Anyone have an idea how to move forward from here?
     
  2. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    looks like yum may be broken on your system

    yum install cairo lcms

    etc
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,696
    Likes Received:
    656
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page