The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

missing '/usr/local/lib/php/extensions/no-debug-non-zts-20090626/ffmpeg.so'

Discussion in 'General Discussion' started by jimlongo, Oct 16, 2012.

  1. jimlongo

    jimlongo Well-Known Member

    Joined:
    Mar 20, 2008
    Messages:
    145
    Likes Received:
    2
    Trophy Points:
    18
    After just updating to 11.34, and also php 5.3.17 and mysql 5.5.27 I'm getting this in error log. I've read other threads on this but am unable to determine the correct course of action.

    php -m | grep -i mcrypt (returns nothing)
    grep -i mcrypt /usr/local/lib/php.ini (returns ;extension=php_mcrypt.dll)

    Code:
    PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20090626/ffmpeg.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20090626/ffmpeg.so: cannot open shared object file: No such file or directory in Unknown on line 0
    Thanks,
    jim
     
  2. jimlongo

    jimlongo Well-Known Member

    Joined:
    Mar 20, 2008
    Messages:
    145
    Likes Received:
    2
    Trophy Points:
    18
    Re: missing '/usr/local/lib/php/extensions/no-debug-non-zts-20090626/ffmpeg

    as well I found the folder '/usr/lib/php/extensions/no-debug-non-zts-20090626/'
    BUT it doesn't contain the file ffmpeg.so

    --edit--
    Sorry for talking to myself, but if I disable
    extension=ffmpeg.so in php.ini the errors stop.

    To install this extension do I need to do it manually, or will easyApache install it?
     
    #2 jimlongo, Oct 16, 2012
    Last edited: Oct 16, 2012
  3. jimlongo

    jimlongo Well-Known Member

    Joined:
    Mar 20, 2008
    Messages:
    145
    Likes Received:
    2
    Trophy Points:
    18
    Re: missing '/usr/local/lib/php/extensions/no-debug-non-zts-20090626/ffmpeg

    This extension is not provided by cPanel or any of it's software.

    I had it previously installed (/usr/lib/php/extensions/no-debug-non-zts-20060613/) but in the upgrade to newer php it was not carried forward, although the line in php.ini remained.

    Thanks.
     
    #3 jimlongo, Oct 16, 2012
    Last edited: Oct 16, 2012
  4. Greenhost

    Greenhost Well-Known Member

    Joined:
    Jan 22, 2013
    Messages:
    92
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    I think, in PHP 5.3.2 the issue is easily resolved, actually:
    look at
    Code:
     /usr/local/lib/php.ini
    
    look for something like this
    Code:
    extension=pdo_sqlite.so
    extension=sqlite.so
    
    And comment it out:
    Code:
    ;;extension=pdo_sqlite.so
    ;;extension=sqlite.so
    
    In addetional this is ionCube Guid
     
Loading...

Share This Page