JustSomeGuy

Active Member
Oct 13, 2007
30
0
56
I have a server running easyapache and suPHP
When a PHP file run by a user creates a directory, it is created as the user nobody and not the user.
If there something I am missing? I would like the directory created as user.user
Also, the only way I will mkdir, is If the directory is set to 777
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Hello :)

I do not recommend using 0777 permissions on a directory due to the security implications of this action. Check to see if suPHP is enabled with the following command:

Code:
/usr/local/cpanel/bin/rebuild_phpconf --current
Thank you.