The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mmcache with PHP 4.3.11

Discussion in 'General Discussion' started by AQHost, Apr 6, 2005.

  1. AQHost

    AQHost Active Member

    Joined:
    Apr 14, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    6
    Anyone having problems getting these two to work together? Removed mmcache from php.ini and restarted Apache before recompiling, did not change any build options other than 4.3.10 to 4.3.11, and did a fresh install of mmcache afterwards (i.e. deleted old directory, downloaded new copy of mmcache etc). Everything seemed to go ok but phpinfo() shows caching enabled as false, and mmcache.php gives the error "Turck MMCache 2.4.6 is not active! It doesn't work in CGI or command line mode!"

    phpsuexec is NOT on and I have confirmed this by running whoami from a PHP script (returns "nobody").

    Thoughts greatly appreciated. It's not a showstopper but it's irritating as mmcache does speed things up somewhat.
     
  2. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    AFAIK, mmcache is no longer developed. Not that I have any experience with this, but you may want to try switching to or trialing an mmcache replacement: http://eaccelerator.net/HomeUk

    I'd assume you may encounter problems as the mmcache is specificially built for older verisons of php and perhaps might require features that are no longer available, etc. You should also consider the fact there may be bugs and or vulnerabilities in the older mmcache.

    That said, I can't confirm any problems with 4.3.11 and mmcache as i don't have any boxes that use them.
     
  3. AQHost

    AQHost Active Member

    Joined:
    Apr 14, 2003
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    6
    Thanks for the reply. I'm loathe to move to eaccelerator as it appears from their forums that it has a problem with the combination of 4.3.11 and phpBB2. Perhaps I just need to wait for another release from them.
     
  4. hbouma

    hbouma Well-Known Member

    Joined:
    Jun 8, 2002
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    mmcache.php is showing as active on my RH7.3 box running 4.3.11 with cPanel 10.1 release 30. It even cached the mmcache.php and info.php script. I haven't done more testing with it yet but it doesn't segfault and reports that its working for me.

    It could be another library has been updated which is causing the problem. I will be testing it on a VPS with RHE before trying it on the rest of my shared servers.

    Hal
     
Loading...

Share This Page