Mobile WHM Login Error - IP Has Changed

CompuTech

Registered
Nov 3, 2010
3
0
51
The new Mobile Browser feature of WHM was a great idea indeed. The only issue I keep having on servers that I mange is that when I use my Blackberry to access WHM I get an error that states "IP Has Changed" after login. This is likely because of the proxy system used through Blackberry, BIS &/or BES.

Is there a way to get rid of the IP change check for mobile when using a Blackberry?

Thanks!
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
The only way to disable the check is to disable it globally, since the idea of the IP check is to ensure the IP doesn't change during transmission of the data, since that's a tactic that can be used for attacks. To disable the option that's causing the issue, you could uncheck this in WHM > Tweak Settings:

Validate the IP addresses used in all cookie based logins. This will limit the ability of attackers who capture cPanel session cookies to use them in an exploit of the cPanel or WebHost Manager interfaces. For this setting to have maximum effectiveness, proxydomains should also be disabled.
Otherwise, if you require that functionality, there is no way to get around the behavior happening for your mobile device.
 

CompuTech

Registered
Nov 3, 2010
3
0
51
Okay, great, thanks!

Forcing SSL should eliminate the risk of someone stealing session cookies, so I think I can live with this IP checking disabled in favor of the convenience of being able to manage WHM via mobile.