The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mod security and 2CO

Discussion in 'Security' started by nimonogi, Sep 23, 2011.

  1. nimonogi

    nimonogi Member

    Joined:
    Mar 11, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I'm trying to use 2Checkout's callbacks (INS) to update my script on successful payments etc.
    However, seems that mod_security on my server blocks 2CO with a 403 forbidden error.

    I have try to add the following to mod_security in WHM:
    Code:
    SecFilterSelective HTTP_User-Agent "2Checkout\.com-purchase libwww-perl\/5\.800" allow
    but i'm getting this error:
    Code:
    Graceful restart requested, doing restart
    Syntax error on line 2 of /usr/local/apache/conf/modsec2.user.conf:
    Invalid command 'SecFilterSelective', perhaps misspelled or defined by a module not included in the server configuration.
    Can you please help to create a filter that allows 2checkout's callbacks to update my script.

    Thanks a lot.
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,446
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  3. nimonogi

    nimonogi Member

    Joined:
    Mar 11, 2011
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    I can't remember if i had install mod_security via Easyapache. Is there any way to check this?
     
    #3 nimonogi, Sep 23, 2011
    Last edited: Sep 23, 2011
Loading...

Share This Page