Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Mod Security WHM Interface not updating

Discussion in 'Security' started by jimlongo, Nov 14, 2013.

  1. jimlongo

    jimlongo Well-Known Member

    Joined:
    Mar 20, 2008
    Messages:
    221
    Likes Received:
    13
    Trophy Points:
    68
    Hi, the Mod Security interface has not updated sine I started using the paid Atomic Rules.
    I see activity in /usr/local/apache/logs/modsec_audit.log but nothing in the WHM interface.

    no corresponding errors in /usr/local/cpanel/logs/error_log
     
  2. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    11
    Trophy Points:
    168
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    Do you have file:
    /etc/cron.hourly/modsecparse.pl
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. jimlongo

    jimlongo Well-Known Member

    Joined:
    Mar 20, 2008
    Messages:
    221
    Likes Received:
    13
    Trophy Points:
    68
    Yes I have that file.

    I am on cpanel 11.40.19
     
  4. Sys Admin

    Sys Admin Well-Known Member

    Joined:
    Apr 29, 2007
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    156
    cPanel Access Level:
    Root Administrator
    Did you try executing it via ssh by running: /etc/cron.hourly/modsecparse.pl ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. jimlongo

    jimlongo Well-Known Member

    Joined:
    Mar 20, 2008
    Messages:
    221
    Likes Received:
    13
    Trophy Points:
    68
    I've done that, and all that happens is it returns without giving any feedback in the terminal.
    After doing that i checked the WHM interface and there is no updated activity.
     
  6. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,442
    Likes Received:
    1,962
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Please open a ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. jimlongo

    jimlongo Well-Known Member

    Joined:
    Mar 20, 2008
    Messages:
    221
    Likes Received:
    13
    Trophy Points:
    68
    Support ID 4396573
     
  8. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,442
    Likes Received:
    1,962
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    To update, it looks like this was the result of the installation of CSF/LFD. The resolution to this issue was resolved by following the instructions from:

    Mod_Sec Log Blank

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. jimlongo

    jimlongo Well-Known Member

    Joined:
    Mar 20, 2008
    Messages:
    221
    Likes Received:
    13
    Trophy Points:
    68
    Yes changing the SecAuditLogType fixes this issue,
    However according to the Atomic people . . .

    SecAuditLogType Serial is not as good in terms of performance in comparison to
    SecAuditLogType Concurrent

    Anyone can comment on this?
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice