The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mod_bandwidth help

Discussion in 'General Discussion' started by TheRaven, Sep 17, 2004.

  1. TheRaven

    TheRaven Member

    Joined:
    Jan 30, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    I am trying to find out what the default settings are for mod_bandwidth. Actually I also want to try bumping them up. What has happened is that Apache seems to be slowing down on serving up graphics. Up until maybe a month ago, or so, my sites (mine and clients) were very snappy. The page generation times haven't changed so it doesn't appear to be a horse power issue. According to my host (I have a dedicated server) he has never made any changes and really knows nothing about the module. My thought process at this point is that possibly because the server is getting alot more traffic, my site in particular, the default values are just too slow now. My home page, for instance, serves up about 118k of images (icons, theme, banner). The banner is only 40k and the rest are smaller icons and/or images. Just for the record, my server is a P4 2.4GHz Dual XEON w/hyper-threading, 1 gig ram. CPU and Memory are very low. The graphic can be seen loading, 1 at a time, in the browser status bar. I never used to have this. Here is a snapshot of my server at this moment:

    Code:
    Server Version: Apache/1.3.31 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 PHP/4.3.8 FrontPage/5.0.2.2634a mod_ssl/2.8.18 OpenSSL/0.9.7a
    Server Built: Jul 15 2004 00:01:27
    
    --------------------------------------------------------------------------------
    Current Time: Friday, 17-Sep-2004 23:26:38 CDT
    Restart Time: Friday, 17-Sep-2004 06:29:43 CDT
    Parent Server Generation: 2 
    Server uptime: 16 hours 56 minutes 55 seconds
    Total accesses: 455782 - Total Traffic: 2.4 GB
    CPU Usage: u1795.65 s371.74 cu.4 cs.38 - 3.55% CPU load
    7.47 requests/sec - 40.7 kB/second - 5.4 kB/request
    5 requests currently being processed, 6 idle servers 
    So, all that to ask, has anyone had similar experiences? What are your thoughts on the possibility? Since I am using a default install (at least I'm told) where are the config files stored? What is the procedure for modifying the bytes per second? If I just comment out the module and the .c lines from the httpd.conf and restart Apache, will that allow Apache to operate at a higher speed than with mod_bandwidth, thereby accomplishing the same thing as bumping up the throttle in mod_bandwidth?

    cPanel and WHM versions:
    Code:
    WHM 9.4.0 cPanel 9.4.1-S65  
    RedHat 9 - WHM X v3.1.0
    Thanks!
     
Loading...

Share This Page