Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mod_dav_svn

Discussion in 'General Discussion' started by morpheous, Feb 23, 2005.

  1. morpheous

    morpheous Member

    Joined:
    Dec 21, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    151
    Hey,

    I was playing around with some stuff on a test box, and I needed a web interface for Subversion.

    So, I installed mod_dav_svn via WHM. Log of install follows:
    Code:
    Gathering header information file(s) from server(s)
    Server: Fedora Core 2 - i386 - Base
    Server: Fedora Core 2 - i386 - Released Updates
    Finding updated packages
    Downloading needed headers
    Resolving dependencies
    .Dependencies resolved
    I will do the following:
    [install: mod_dav_svn 1.0.9-1.i386]
    I will install/upgrade these to satisfy the dependencies:
    [deps: httpd 2.0.51-2.9.i386]
    Downloading Packages
    Getting httpd-2.0.51-2.9.i386.rpm
    
    httpd-2.0.51-2.9.i386.rpm   0% |                         |    0 B    --:-- ETA 
    httpd-2.0.51-2.9.i386.rpm   2% |                         |  24 kB    00:16 ETA 
    httpd-2.0.51-2.9.i386.rpm   9% |==                       |  88 kB    00:14 ETA 
    httpd-2.0.51-2.9.i386.rpm  20% |=====                    | 184 kB    00:12 ETA 
    httpd-2.0.51-2.9.i386.rpm  30% |=======                  | 280 kB    00:10 ETA 
    httpd-2.0.51-2.9.i386.rpm  45% |===========              | 416 kB    00:08 ETA 
    httpd-2.0.51-2.9.i386.rpm  59% |==============           | 536 kB    00:06 ETA 
    httpd-2.0.51-2.9.i386.rpm  72% |==================       | 656 kB    00:04 ETA 
    httpd-2.0.51-2.9.i386.rpm  90% |======================   | 816 kB    00:01 ETA 
    httpd-2.0.51-2.9.i386.rpm 100% |=========================| 905 kB    00:02     
    Getting mod_dav_svn-1.0.9-1.i386.rpm
    
    mod_dav_svn-1.0.9-1.i386.   0% |                         |    0 B    --:-- ETA 
    mod_dav_svn-1.0.9-1.i386.  50% |============             |  24 kB    00:00 ETA 
    mod_dav_svn-1.0.9-1.i386. 100% |=========================|  47 kB    00:00     
    Running test transaction:
    Test transaction complete, Success!
    
    httpd 0 % done 1/2
    httpd 0 % done 1/2
    httpd 0 % done 1/2
    httpd 0 % done 1/2
    httpd 0 % done 1/2
    httpd 1 % done 1/2
    httpd 2 % done 1/2
    httpd 2 % done 1/2
    httpd 100 % done 1/2 
    
    mod_dav_svn 0 % done 2/2
    mod_dav_svn 11 % done 2/2
    mod_dav_svn 81 % done 2/2
    mod_dav_svn 99 % done 2/2
    mod_dav_svn 100 % done 2/2 
    Installed:  mod_dav_svn 1.0.9-1.i386
    Dep Installed:  httpd 2.0.51-2.9.i386
    Transaction(s) Complete
    Install Complete
    Now, I knew it'd install Apache 2 (That's what the mod's written for), but i'm unsure on how to configure Apache 1.3.33 and Apache 2.0.51 to run happily together on different ports (1.3 on 80, 2 on 7654 or something).

    Any help? If someone could point me at the apache 2 folder, that'd be great too :p

    Cheers,
    Morph
     
  2. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    318
    If you must install by rpm, you may need to alter the source rpm to ensure the install doesn't interfere with the existing source install of 1.3.33, rebuild that then install. I usually tend to recommend installation from source in this case. As for the port, there should be a configuration option in the httpd.conf. If the httpd2 option is the same as v.1 then run a search for "listen" in the httpd.conf file.

    Hope that helps.
     
Loading...

Share This Page