SOLVED Mod_Deflate not Working after Updating to EA4

leslieurance

Registered
Jan 2, 2017
2
1
3
United States
cPanel Access Level
Root Administrator
I need some help. I updated to EA4 and enabled multip php versions and everything appeared to work correctly.

After the update was completed, I noticed that gzip is no longer working. I verified its installed, but it is not working.

I read on another thread to change the php handler from cgi to suphp, but that immediately broke my site, so i switched the handler back to cgi.

At this point, I'm not sure what to do. Can someone point me in the right direction?
 

leslieurance

Registered
Jan 2, 2017
2
1
3
United States
cPanel Access Level
Root Administrator
Solved: I revisited my settings. In WHM, I went to the Home>Software>MultiPHP Manager and noticed that PHP-FPM was not turned on by default.

Somehow I missed that when I switched my site over to PHP 7. Once I turned PHP-FPM on, mod_deflate started working correctly.
 
Last edited:
  • Like
Reactions: TheNewb

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,229
463
Solved: I revisited my settings. In WHM, I went to the Home>Software>MultiPHP Manager and noticed that PHP-FPM was not turned on by default.

Somehow I missed that when I switched my site over to PHP 7. Once I turned PHP-FPM on, mod_deflate started working correctly.
Hello,

I'm happy to see the issue is now resolved. Thank you for updating us with the outcome.