The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mod_gzip error brings down apache

Discussion in 'EasyApache' started by Domenico, Nov 19, 2002.

  1. Domenico

    Domenico Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    361
    Likes Received:
    0
    Trophy Points:
    16
    Anyone knows what this means?

    [Tue Nov 19 17:44:58 2002] [error] mod_gzip: EMPTY FILE [/tmp/_13898_99_0.wrk] in sendfile2
    [Tue Nov 19 17:44:58 2002] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
    [Tue Nov 19 17:44:58 2002] [error] mod_gzip: EMPTY FILE [/tmp/_27262_99_0.wrk] in sendfile2
    [Tue Nov 19 17:44:58 2002] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
    [Tue Nov 19 17:45:00 2002] [error] mod_gzip: EMPTY FILE [/tmp/_15192_170_71.wrk] in sendfile2
    [Tue Nov 19 17:45:00 2002] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
    [Tue Nov 19 17:45:01 2002] [error] mod_gzip: EMPTY FILE [/tmp/_4847_176_77.wrk] in sendfile2
    [Tue Nov 19 17:45:01 2002] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
    [Tue Nov 19 17:45:04 2002] [error] mod_gzip: EMPTY FILE [/tmp/_10607_184_85.wrk] in sendfile2
    [Tue Nov 19 17:45:04 2002] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
    [Tue Nov 19 17:45:04 2002] [error] mod_gzip: EMPTY FILE [/tmp/_21604_101_2.wrk] in sendfile2
    [Tue Nov 19 17:45:04 2002] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
    [Tue Nov 19 17:45:04 2002] [error] mod_gzip: EMPTY FILE [/tmp/_13898_100_1.wrk] in sendfile2
    [Tue Nov 19 17:45:04 2002] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
    [Tue Nov 19 17:45:05 2002] [error] mod_gzip: EMPTY FILE [/tmp/_27262_100_1.wrk] in sendfile2
    [Tue Nov 19 17:45:05 2002] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
    [Tue Nov 19 17:45:05 2002] [error] mod_gzip: EMPTY FILE [/tmp/_25543_100_1.wrk] in sendfile2
    [Tue Nov 19 17:45:05 2002] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
    [Tue Nov 19 17:45:07 2002] [notice] caught SIGTERM, shutting down
     
  2. ozzi4648

    ozzi4648 Guest

    Ye its means get rod of mod_gzip. The problem your experiencing appears when your trying to use mod_gzip under SSL. So if your running a credit card billing system your probably using SSL? Then what happens is when the compression occurs under SSL the following errors appear. I know, i have been thru this before on my other boxes and i simply removed mod_gzip. Its really a problem module. It also creates alot of segfaults
     
  3. Juanra

    Juanra Well-Known Member

    Joined:
    Sep 22, 2001
    Messages:
    777
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Spain
    We are using mod_gzip together with SSL with no problems.

    Could be a full tmp partition?
     
  4. rcthost

    rcthost Active Member

    Joined:
    Sep 16, 2002
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    How do you safely remove mod_gzip?
     
  5. ozzi4648

    ozzi4648 Guest

    [quote:dbbca648d0][i:dbbca648d0]Originally posted by Juanra[/i:dbbca648d0]

    We are using mod_gzip together with SSL with no problems.

    Could be a full tmp partition?[/quote:dbbca648d0]

    I dont believe you. Time to look at your logs to find the errors that are obviously passing by you. SSL and mod_gzip are a major problem on all systems, unless you &PAID& for the latest version which takes care of this issue, which i dont think you did so look at your logs again. Even so you probably wouldnt admit it so why post?
     
  6. Juanra

    Juanra Well-Known Member

    Joined:
    Sep 22, 2001
    Messages:
    777
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Spain
    [quote:ffe935e557][i:ffe935e557]Originally posted by ozzi4648[/i:ffe935e557]
    I dont believe you. Time to look at your logs to find the errors that are obviously passing by you. SSL and mod_gzip are a major problem on all systems, unless you &PAID& for the latest version which takes care of this issue, which i dont think you did so look at your logs again. Even so you probably wouldnt admit it so why post?[/quote:ffe935e557]

    Hum, you're right. Sorry for the wrong info. Rather than removing mod_gzip altogether, you can add this

    mod_gzip_on No

    inside SSL virtual hosts. I guess this doesn't really solve the problem, but I still think it's better than removing mod_gzip.
     
  7. ozzi4648

    ozzi4648 Guest

    [quote:1b90c637a9][i:1b90c637a9]Originally posted by Juanra[/i:1b90c637a9]

    [quote:1b90c637a9][i:1b90c637a9]Originally posted by ozzi4648[/i:1b90c637a9]
    I dont believe you. Time to look at your logs to find the errors that are obviously passing by you. SSL and mod_gzip are a major problem on all systems, unless you &PAID& for the latest version which takes care of this issue, which i dont think you did so look at your logs again. Even so you probably wouldnt admit it so why post?[/quote:1b90c637a9]

    Hum, you're right. Sorry for the wrong info. Rather than removing mod_gzip altogether, you can add this

    mod_gzip_on No

    inside SSL virtual hosts. I guess this doesn't really solve the problem, but I still think it's better than removing mod_gzip.[/quote:1b90c637a9]

    I know very well the problems assocaited with mod_gzip. I spent almost a week on the issue till i realized that when a user access any files from our secure server at http://www.secure.mydomain.com and goes inside our billing module, modernbill it creates all kinds of errors in the logs. Again, its got to do with SSL and the way mod_gzip handles it.
     
  8. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    [quote:4b10318d43][i:4b10318d43]Originally posted by ozzi4648[/i:4b10318d43]I know very well the problems assocaited with mod_gzip. I spent almost a week on the issue till i realized that when a user access any files from our secure server at http://www.secure.mydomain.com and goes inside our billing module, modernbill it creates all kinds of errors in the logs. Again, its got to do with SSL and the way mod_gzip handles it.[/quote:4b10318d43]

    I run ModernBill with SSL and Mod Gzip and have no problems. The only problems I have ever had with mod gzip is when .wrk files are created that are so large they fill the /tmp partition.

    EDIT: I checked the ssl error log and the mod_gzip: EMPTY FILE [/tmp/_4104_105_6.wrk] in sendfile2 messages are present but does not cause Apache to crash. I even tailed the error log while accessing the site via SSL and Apache didn't crash or restart.
     
  9. moronhead

    moronhead Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    706
    Likes Received:
    0
    Trophy Points:
    16
    The problems with mod_gzip filling up the /tmp directory in a matter of seconds with gigantic multi-gig files seems to be legendary. But don't blame it all on mod_gzip; it can be a badly written php script as well.

    There's a simple solution that I've devised and been using it with success.

    1. Change the tmp directory for mod_gzip in your in httpd.conf to the largest free space partition. You can also try to tweak the settings while you're in there.

    2. In /etc/crontab put a cron job that clears any temp files every two minutes:

    0-58/2 * * * * root touch /home/gzip/tmp56.wrk
    1-59/2 * * * * root rm /home/gzip/*.wrk

    Regards,
    Norman
     
  10. Sash

    Sash Well-Known Member

    Joined:
    Feb 18, 2003
    Messages:
    252
    Likes Received:
    0
    Trophy Points:
    16
    What permissions should be set on the directory and who should own the directory?

    Thanks,
    Mike
     
Loading...

Share This Page