mod_http2 conflicts error while installing

Joseph Miller

Registered
Nov 24, 2017
1
0
1
India
cPanel Access Level
Root Administrator
Hello guys,

I tried this method

--------------------------------

>> Apache Module: HTTP2 - EasyApache 4 - cPanel Documentation

On the command line
To install the mod_http2 Apache module in EasyApache 4, run the following command on the command line:

yum install ea-apache24-mod_http2

---------------------------------------

But i end up with conflict error...

Snap_2017.11.24_11h38m22s_003_.png

and then i thougt to remove the conflit file..

Yum remove ea-apache24-mod_mpm_prefork

but i got these infos.. so i have no idea.. while this removal of mod prefork... removed all these dependencies?

Snap_2017.11.24_11h40m19s_004_.png

I need to use HTTP2 with SPDY... pleas help me to solve this issue :) thanks.. and waiting..
 

sahostking

Well-Known Member
May 15, 2012
395
23
68
Cape Town, South Africa
cPanel Access Level
Root Administrator
Twitter
Dont think it works with Prefork. You have to switch to MPM worker or Event to use http2.

Note it is probably possible to use http2 with mpm prefork however your may sit with many restrictions or apache processes stalling:

Found the information on apache site: https://httpd.apache.org/docs/trunk/howto/http2.html#mpm-config
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello,

Mod_HTTP2 is not compatible with the Prefork MPM. This is discussed (with alternatives to Prefork) on the following thread:

Prefork and HTTP2

Thank you.