Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Mod_Mono - How to make it work with .asp extensions?

Discussion in 'General Discussion' started by fizz, Dec 14, 2009.

  1. fizz

    fizz Well-Known Member

    Joined:
    Jan 25, 2002
    Messages:
    202
    Likes Received:
    0
    Trophy Points:
    316
    I have a customer who is only using ASP for a couple contact forms, but at this point his whole site is done with .asp (no actual code in 90% of the files grrrr). I tried adding a "AddType application/x-asp-net .asp" to the mod_mono config file, but this will make it prompt to download the file. Firefox see's it as a text/asp, but so far have had no luck getting it to work properly. If i rename one of his files to .aspx, it works.

    What am i missing here?
     
  2. fizz

    fizz Well-Known Member

    Joined:
    Jan 25, 2002
    Messages:
    202
    Likes Received:
    0
    Trophy Points:
    316
    I also understand Mono will not work with most classic asp, I just want it to display the site so they dont have to rewrite a ton of code, and i can make the couple contact forms work..
     
  3. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    4
    Trophy Points:
    343
    Location:
    ON, Canada
    Are the asp files being uploaded from Windows? If so, make sure they are uploaded in ascii, not binary. We recently enabled asp on a server for a customer who was desperate to use basic asp functions and they had trouble getting their pages to work, until I realized they had uploaded in binary. Most ftp programs don't have .asp in their ascii list yet.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. fizz

    fizz Well-Known Member

    Joined:
    Jan 25, 2002
    Messages:
    202
    Likes Received:
    0
    Trophy Points:
    316
    They were uploaded properly. If i renamed the file to .aspx, everything worked.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice