Mod_Mono Install Error - 404 Error

Drewley

Member
Oct 30, 2006
16
0
151
Trying to install mod_mono from whm, here is log:

Code:
Updating modmono....

Fetching http://httpupdate.cpanel.net/cpanelsync/addons/modules/modmono-Linux-i686/.cpanelsync.lock (0)[email protected]
Fetching http://httpupdate.cpanel.net/cpanelsync/addons/modules/modmono-Linux-i686.tar.bz2 (0)[email protected]%......Done
Fetching http://httpupdate.cpanel.net/cpanelsync/addons/modules/modmono-Linux-i686/.cpanelsync.bz2 (0)[email protected]%......Done
Fetching http://httpupdate.cpanel.net/cpanelsync/addons/modules/modmono-Linux-i686/addasp.bz2 (0)[email protected]%......Done
Got file ./addasp ok (md5 matches)
Fetching http://httpupdate.cpanel.net/cpanelsync/addons/modules/modmono-Linux-i686/install.bz2 (0)[email protected]%......Done
Got file ./install ok (md5 matches)
Fetching http://httpupdate.cpanel.net/cpanelsync/addons/modules/modmono-Linux-i686/uninstall.bz2 (0)[email protected]%......Done
Got file ./uninstall ok (md5 matches)
Fetching http://httpupdate.cpanel.net/cpanelsync/addons/modules/modmono-Linux-i686/delasp.bz2 (0)[email protected]%......Done
Got file ./delasp ok (md5 matches)
Fetching http://httpupdate.cpanel.net/cpanelsync/addons/modules/modmono-Linux-i686/cPanelEA/Apache1/YAddon_Modules__S/Mod_Mono.pm.bz2 (0)[email protected]%......Done
Got file ./cPanelEA/Apache1/YAddon_Modules__S/Mod_Mono.pm ok (md5 matches)
Fetching http://httpupdate.cpanel.net/cpanelsync/addons/modules/modmono-Linux-i686/cPanelEA/Apache1/YAddon_Modules__S/Mod_Mono.pm.tar.gz.bz2 (0)[email protected]%...2%...3%...4%...5%...6%...7%...8%...9%...10%...11%...12%...13%...14%...15%...16%...17%...18%...19%...20%...21%...22%...23%...24%...25%...26%...27%...28%...29%...30%...31%...32%...33%...34%...35%...36%...37%...38%...39%...40%...41%...42%...43%...44%...45%...46%...47%...48%...49%...50%...51%...52%...53%...54%...55%...56%...57%...58%...59%...60%...61%...62%...63%...64%...65%...66%...67%...68%...69%...70%...71%...72%...73%...74%...75%...76%...77%...78%...79%...80%...81%...82%...83%...84%...85%...86%...87%...88%...89%...90%...91%...92%...93%...94%...95%...96%...97%...98%...99%...100%......Done
Got file ./cPanelEA/Apache1/YAddon_Modules__S/Mod_Mono.pm.tar.gz ok (md5 matches)
Fetching http://httpupdate.cpanel.net/cpanelsync/addons/modules/modmono-Linux-i686/version.bz2 (0)[email protected]%......Done
Got file ./version ok (md5 matches)
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/easyapache/setup_for_ea
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/easyapache/setup_for_ea
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/easyapache/setup_for_ea
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/easyapache/setup_for_ea
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/easyapache/setup_for_ea
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/easyapache/setup_for_ea
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/easyapache/setup_for_ea
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/easyapache/setup_for_ea
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/easyapache/setup_for_ea
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/easyapache/setup_for_ea
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/easyapache/setup_for_ea
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/easyapache/setup_for_ea
Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/easyapache/setup_for_ea

Done

Process Complete
as you can see it cant find: http://httpupdate.cpanel.net//cpanelsync/easyapache/setup_for_ea
maybe some kind of url typo from the cpanel guys?

please advise.
 

cooldude7273

Well-Known Member
Jan 11, 2004
357
0
166
Roswell, GA
The mod_mono that is installed with Apcahe 1 is vastly out of date and doesn't work at all. Trust me, I've been through hell trying to get it to work. After many days of support tickets with cPanel trying to get their 1.0.1 mod_mono module to work, they essentially gave up and simply installed it manually for me.

... which is what I would recommend doing.
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
80
458
cPanel Access Level
Root Administrator
As cooldude said, don't use the mod_mono Plugin. cPanel 11 stage 2 has an up-to-date installer which simplifies this. In the interim, installing the latest mod_mono is very simple to do. If you don't want to mess with it, there is a script here: http://bugzilla.cpanel.net/attachment.cgi?id=403 which will perform this task for you.
 

manuxer

Active Member
Aug 16, 2006
30
0
156
I compiled mod_mono in apache 2.2.6 with easyapache, do i need to use this script also?
And i don't have /scripts/addasp , how can i add aspx support for a domain, with mod_mono?
Thank you!
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
80
458
cPanel Access Level
Root Administrator
mod_mono support is automatically available to all accounts/domains. /scripts/addasp was part of the older BETA Plugin, and is no longer supported.