Krownet

Active Member
Sep 16, 2005
38
0
156
Hello,

On my development server, I'm wanting to mess around with ASP without going to the trouble of getting a Windows server setup for the 3 months which I need it. So I decided to checkout Mod_Mono.

I searched quite a bit on the forums, and spent a few hours searching google for some answers, but have come up dry. I ran the Mod_mono through cpanel Plugins. The version it installs is from 2004 (version 1.0.2) . That's a looong time ago. And the version it installs has a precarious bug, which causes it to display 503 Service Temporarily Unavailable (I found this bug report .. which has been fixed).

So, I decided to try to install it on my own. The latest version doesn't work (some APR file is missing, I can only assume that is because it's meant to run with Apache 2... not sure though). So I tried installing an earlier version, same problem.

I'm getting kind of anxious here, wanting to play with Mod_Mono. Why has this module been in "Beta" and not updated for 3 years? I know it's not very important (not a lot of users use it), but 3 years is kinda of ridiculous.

Now for the question (I do have one) has anyone successfully gotten Mod_Mono to work? If so, how did you do it? I've tried everything I can think of, and everything that I can see the web has suggested. Help...

Thanks.
 
Last edited:

SCARECR0W

Registered
Jul 27, 2007
2
0
51
Yes, Please...

Someone tell me that this is possible to install and run. I have one super simple, little asp app (online football pool that uses Access db) and I currently am paying for a separate windows box that I would love to get rid of if I can get this installed and running on my new dedicated box.

I too have search for success stories, tips, anything - and found nada... not a good sign.

Is there any other method for running basic asp scripts on a linux box? I don't really even need .net stuff, classic asp will work for my needs.

Thanks!
 

Krownet

Active Member
Sep 16, 2005
38
0
156
From the errors that I've seen, I can only conclude that I need Apache 2.x to get this running (least with the latest version of Mod_Mono). I'm not sure if this is right, but I'm waiting for the 2nd release of cPanel 11 Current (which has been pushed back multiple times now) so I can see if that works.

Hopefully someone knows how to get it running before then.

Cheers,