Amgeek

Member
Nov 7, 2013
22
1
3
cPanel Access Level
Website Owner
It was suggested to me that I might want to install mod_pagespeed on my server (CentOS 7.5, Apache 2.4.34 , cpanel 74.0.4)

Question 1: Is this any different/better from the item at Cpanel as cPanel >> Home >> Software >> Optimize Website ???

Question 2. If they are not the same how do I install mod_pagespeed. I have tried several times but without success. Closest by following instructions here:
Installing mod_pagespeed with Apache on Ubuntu/CentOS – E2E Networks Knowledgebase

# yum update
# yum upgrade
both report nothing to do


wget https://dl-ssl.google.com/dl/linux/direct/mod-pagespeed-stable_current_x86_64.rpm


yum install at
ran but reports nothing to do
rpm -U mod-pagespeed-*.rpm

Generates error



warning: mod-pagespeed-beta_current_x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 7fac5991: NOKEY

error: Failed dependencies:

httpd >= 2.2 is needed by mod-pagespeed-beta-1.13.35.2-0.x86_64

mod-pagespeed-stable conflicts with mod-pagespeed-beta-1.13.35.2-0.x86_64

httpd >= 2.2 is needed by mod-pagespeed-stable-1.13.35.2-0.x86_64

mod-pagespeed-beta conflicts with mod-pagespeed-stable-1.13.35.2-0.x86_64



Any guidance would be appreciated.



Thanks

Ed
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello @Amgeek,

The inclusion of PageSpeed in EasyApache 4 is not yet stable, but we do have an experimental RPM you can test. Information about how to install it is found on the corresponding feature request page:

Add support for mod_pagespeed to easyapache4

Thank you.