The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mod_perl

Discussion in 'General Discussion' started by dmuey, Dec 29, 2003.

  1. dmuey

    dmuey Member

    Joined:
    Nov 25, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Under "update Apache" in WHM it says:
    Perl Module (not required to run .cgi scripts/not compatible with php) (Version 1.28)

    I couldn't find any reference on google about that incompatibility. I'd love to have mod_perl enabled, I'd even be willing to ditch php if cpanel didn't use it, but obviously we're stuck with it.

    Could any one shed any light as to why that says that and any links to these incompatibility issues?

    here's a link I could find about it:
    http://www.zend.com/zend/week/week14-15-16-17.php#Heading11

    TIA

    Dan
     
    #1 dmuey, Dec 29, 2003
    Last edited: Dec 29, 2003
  2. cortices

    cortices Well-Known Member

    Joined:
    Mar 10, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Dallas, TX
    I'd also like to hear if anyone has any issues running mod_perl with mod_php.

    From the link you posted, it looks as if any compatibilities issues were resolved with PHP 4.0.4. I might end up enabling it and seeing if anything happens.
     
  3. dmuey

    dmuey Member

    Joined:
    Nov 25, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Let us know if it works!!!!
     
  4. dmuey

    dmuey Member

    Joined:
    Nov 25, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Anyone try adding mod_perl via the latest version of WHM->Software->Update Apache ??

    cortices?

    Also:
    Where does that script get it's list of modules to give checkboxes to?

    I'd like to add one or two so I can have them checked or not when i run this page.
     
  5. cortices

    cortices Well-Known Member

    Joined:
    Mar 10, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Dallas, TX
    Well, as of a few days ago there appears to be a conflict between the version of mod_perl easyapache uses (1.2.8) and Apache 1.3.29. 1.2.8 appeared to work fine with 1.3.28 but will not even compile with 1.3.29.

    I am thinking of manually installing the latest mod_perl from perl.apache.org. I'll let you know how it goes.
     
  6. cortices

    cortices Well-Known Member

    Joined:
    Mar 10, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Dallas, TX
    I installed mod_perl 1.29 via the apxs method and everything appears to be fine. I will keep an eye on it though and see how things go.
     
  7. lgwong

    lgwong Member

    Joined:
    Oct 11, 2003
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Can you list the steps how t install mod_perl 1.29 using apxs? Thanks.
     
  8. eglwolf

    eglwolf Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
  9. cortices

    cortices Well-Known Member

    Joined:
    Mar 10, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Dallas, TX
    Yeah, read eglwolf's thread. Follow those instructions and you shouldn't have a problem.
     
  10. lgwong

    lgwong Member

    Joined:
    Oct 11, 2003
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    thanks a lot

    I found that the script are not running very fast after install mod_perl. Am I doing things correctly by replacing

    ScriptAlias /cgi-bin/ /home/lgwong/public_html/cgi-bin/

    with

    Alias /cgi-bin/ /home/lgwong/public_html/cgi-bin/
    PerlModule Apache::PerlRun
    <Location /perl/>
    SetHandler perl-script
    PerlHandler Apache::PerlRun
    Options ExecCGI
    PerlSendHeader On
    allow from all
    </Location>
     
  11. lgwong

    lgwong Member

    Joined:
    Oct 11, 2003
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I was so stupid, forget to change /perl/ to /cgi-bin/

    But problem now arise again, scripts don't work as they should be. A scripts should make use of LWP::Parallel perl module to fetch some external results. After changing to use mod_perl, it can no longer make use of the LWP::Parallel. Any idea how to make this work?
     
  12. cortices

    cortices Well-Known Member

    Joined:
    Mar 10, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Dallas, TX
    It's actually a mistake to make make mod_perl the handler for the cgi-bin directory. Firstly, as you have noticed, not all Perl scripts are compatible with mod_perl. Secondly, cgi scripts can be written a larger number of languages. While Perl is far and away the more popular choice, by making mod_perl the handler for the cgi-bin/ directory, you are disabling any scripts not written in Perl.

    Standard practice is to have an additional, cgi-perl or perl directory for all mod_perl or compatible perl scripts.
     
  13. drmueyx

    drmueyx Active Member

    Joined:
    Oct 6, 2003
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    Awesome!
    Thanks!
    http://forums.cpanel.net/showthread...&threadid=18570
    will seem to work I hope.

    After it is installed and working and we have the easy way to re add it after /scripts/easyapache...

    1)What is the best way to make it so all users have the perl-bin/ directory?
    Add it to the skeleton files?
    What permissions?

    2) What is the best way to enable it in httpd.conf?
    One main entry or the same entry for each virtual host?

    TIA
    Dan
     

Share This Page