The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mod_php differs

Discussion in 'General Discussion' started by clexmarker, Aug 4, 2007.

  1. clexmarker

    clexmarker Registered

    Joined:
    Dec 28, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I installed apache and php 5.2.3 from whm's apache update page. I installed eaccelerator and zend optimizer. i restarted apache so that it will load the modified php.ini file. Now i tried this command in the shell and i got this.

    php -v

    PHP 5.2.3 (cli) (built: Aug 4 2007 13:31:30)
    Copyright (c) 1997-2007 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with eAccelerator v0.9.5.1, Copyright (c) 2004-2006 eAccelerator, by eAccelerator
    with Zend Extension Manager v1.2.0, Copyright (c) 2003-2006, by Zend Technologies
    with Zend Optimizer v3.2.2, Copyright (c) 1998-2006, by Zend Technologies


    Now i made a info.php on the server and opened it in the browser and suprisingly it had everything just exactly how i set it up in the php.ini file except for the area where it shows the dynamic libraries it only showed this:

    This program makes use of the Zend Scripting Language Engine:
    Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies


    I couldn't see any eaccelerator or zend optimizer. I tried recomiling apache and php many times however i still have this problem ... anyone can help me with this please. Thanks. I have cpanel 11 Latest (Release), Cent OS 5.
     
    #1 clexmarker, Aug 4, 2007
    Last edited: Aug 4, 2007
  2. color

    color Active Member

    Joined:
    Aug 31, 2006
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    there are 2 instances of PHP in the system,
    /usr/bin/php and
    /usr/local/bin/php
     

Share This Page