Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mod_qos Apache 2.4

Discussion in 'EasyApache' started by Zabidin, Jan 12, 2016.

  1. Zabidin

    Zabidin Well-Known Member

    Joined:
    Jan 6, 2016
    Messages:
    48
    Likes Received:
    4
    Trophy Points:
    8
    Location:
    Malaysia
    cPanel Access Level:
    Root Administrator
    Hi,

    Is it possible i'm using this mod_qos on apache 2.4? Please advice.

    Thanks.
     
  2. cPJacob

    cPJacob cPanel Product Owner
    Staff Member

    Joined:
    May 2, 2014
    Messages:
    602
    Likes Received:
    92
    Trophy Points:
    103
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hello,

    mod_qos does compile with Apache 2.4, but a few of it's directives are broken and don't work properly. I would not recommend using mod_qos any longer. What needs do you have that require mod_qos? What are you trying to achieve?
     
  3. bouvrie

    bouvrie Active Member

    Joined:
    Apr 6, 2012
    Messages:
    33
    Likes Received:
    6
    Trophy Points:
    58
    cPanel Access Level:
    Root Administrator
    Bumping this, as I want to have more control over the number of requests a single client can make/fight malicious traffic. I came across mod_qos,
    mod_limitipconn, mod_cband and mod_evasive. The latter of which seems like a good runner up choice. Most install instructions reference EasyApache3, while we're on EasyApache 4. Can anyone suggest a course of action?
     
  4. cPJacob

    cPJacob cPanel Product Owner
    Staff Member

    Joined:
    May 2, 2014
    Messages:
    602
    Likes Received:
    92
    Trophy Points:
    103
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hi,

    I build mod_qos for EA4, but it's not being distributed by cPanel right now. Could you test this out and let me know how it works?

    Show home:Jperkster:EA4-mod_qos - openSUSE Build Service

    It's only available for CentOS 6 right now. You can install it by running:

    Code:
    wget -O /etc/yum.repos.d/EA4-qos.repo http://download.opensuse.org/repositories/home:/Jperkster:/EA4-mod_qos/CentOS_6/home:Jperkster:EA4-mod_qos.repo
    Then do 'yum install ea-apache24-mod_qos'.

    Thanks!
     
    #4 cPJacob, Dec 5, 2016
    Last edited: Feb 13, 2017
  5. Julianishaqi

    Julianishaqi Registered

    Joined:
    Apr 19, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sweden
    cPanel Access Level:
    Root Administrator
    Hello

    I have tried to install the build in centos7 here
    software.opensuse.org: Install package home:Jperkster:EA4-mod_qos / ea-apache24-mod_qos

    But im getting this error

    yum install ea-apache24-mod_qos
    Loaded plugins: fastestmirror, universal-hooks
    Loading mirror speeds from cached hostfile
    * EA4: 91.197.228.252
    * cpanel-addons-production-feed: 91.197.228.252
    * base: mirror.nsc.liu.se
    * extras: mirror.nsc.liu.se
    * updates: mirror.nsc.liu.se
    Resolving Dependencies
    --> Running transaction check
    ---> Package ea-apache24-mod_qos.x86_64 0:11.36-1.2.14 will be installed
    --> Processing Dependency: libpcre.so.0()(64bit) for package: ea-apache24-mod_qo s-11.36-1.2.14.x86_64
    --> Finished Dependency Resolution
    Error: Package: ea-apache24-mod_qos-11.36-1.2.14.x86_64 (home_Jperkster_EA4-mod_ qos)
    Requires: libpcre.so.0()(64bit)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest



    Any idea how to resolve this?
     
Loading...

Share This Page