The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mod_rewrite not enabled

Discussion in 'General Discussion' started by pchard, Sep 13, 2016.

Tags:
  1. pchard

    pchard Registered

    Joined:
    Sep 13, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Norway
    cPanel Access Level:
    Root Administrator
    Hello.

    How do I enable mod_rewrite?

    [root@cpanel ~]# httpd -l|grep rewrite
    [root@cpanel ~]#


    It looks to me it's not enabled, and I need some assistance.

    The reason for why I'm asking is this:

    public_html/.htaccess: </IfModule>IndexOptions without matching <IfModule>IndexOptions section
     
    #1 pchard, Sep 13, 2016
    Last edited by a moderator: Sep 13, 2016
  2. cPJacob

    cPJacob cPanel Product Owner
    Staff Member

    Joined:
    May 2, 2014
    Messages:
    510
    Likes Received:
    66
    Trophy Points:
    28
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hi,

    If you are on EA3, you need 'httpd -M', as these modules are no longer compiled statically. In EA4, mod_rewrite is enabled by default.

    Code:
    root@cpanel [~]# httpd -M | grep rewri
     rewrite_module (shared)
    
     
  3. Najbox

    Najbox Registered

    Joined:
    Oct 14, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    France
    cPanel Access Level:
    Root Administrator

    I have the same problem and I use EA4.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello @Najbox,

    Could you provide some more information about the problem you are currently facing? Do you not see similar output when running the "httpd -M | grep rewrite" command on your system?

    Thanks.
     
Loading...

Share This Page