The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mod_Sec Version?

Discussion in 'General Discussion' started by Fernis, Jun 8, 2008.

  1. Fernis

    Fernis Well-Known Member

    Joined:
    Oct 28, 2006
    Messages:
    192
    Likes Received:
    1
    Trophy Points:
    18
    What version of mod_sec is being installed if it is compiled when using apache easyupdate in WHM?
     
  2. DaveUsedToWorkHere

    DaveUsedToWorkHere Well-Known Member

    Joined:
    Dec 28, 2001
    Messages:
    689
    Likes Received:
    1
    Trophy Points:
    18
    2.1 at the moment, we will be including 2.5 very shortly
     
  3. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    If you are using EasyApache and select Apache 1.3, mod_security 1.9.5 is installed. If you are using EasyApache and select Apache 2.0 or 2.2, mod_security 2.1.4 is installed.
     
  4. Fernis

    Fernis Well-Known Member

    Joined:
    Oct 28, 2006
    Messages:
    192
    Likes Received:
    1
    Trophy Points:
    18
    Thank you very much gentelmen. :)
     
  5. dexus

    dexus Well-Known Member

    Joined:
    Jan 14, 2006
    Messages:
    169
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Will mod_security be upgraded to new version automatically by upcp or we should rebuild Apache with EasyApache to get new version.

    Do you have any idea when will mod_sec be upgraded to new version?
     
  6. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Apache, PHP and modules for Apache (such as mod_security) and PHP are only upgraded upon running EasyApache.
     
Loading...

Share This Page