The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

mod_security 2.1.4 and the latest rule set (1.5.1)

Discussion in 'Security' started by DReade83, Dec 19, 2007.

  1. DReade83

    DReade83 Well-Known Member

    Joined:
    Oct 20, 2006
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cheshire, UK
    Has anyone else managed to get the latest rule set, version 1.5.1, working with their mod_security 2.1.4 installation? I'm trying to get it running on my test server, but seeing the following error in Apache's startup error log:

     
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    mod_security is not currently built with support for XML (see http://bugzilla.cpanel.net/show_bug.cgi?id=6207 - apologies if you are the one that opened the report). Thus rules that contain XML will need removed until we change mod_security to build with XML support
     
Loading...

Share This Page