The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mod_security and EasyApache 4

Discussion in 'EasyApache' started by opt2bout, Oct 7, 2015.

  1. opt2bout

    opt2bout Well-Known Member

    Joined:
    Nov 10, 2006
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    I have moved to EA4 and had to have cPanel do some manual adjustments to get it going.

    Mod security is installed, but I'm just posting here to see if the WHM interface should be used to manage EA4's implementation of mod_security. If we try to make a change to the configuration we get:

    Error: The system could not save your ModSecurity™ settings because of the following error: The system could not deploy your configuration changes due to the following error: The system could not validate the new Apache configuration because httpd exited with a nonzero value. Apache produced the following error: httpd: Syntax error on line 219 of /etc/apache2/conf/httpd.conf: Syntax error on line 29 of /etc/apache2/conf.d/modsec2.cpanel.conf: Could not open configuration file /etc/apache2/conf.d/modsec_vendor_configs/OWASP/modsecurity_crs_10_setup.conf: No such file or directory​

    Also the mod_security vendors aren't available for installation, etc.
     
  2. cPJacob

    cPJacob cPanel Product Owner
    Staff Member

    Joined:
    May 2, 2014
    Messages:
    508
    Likes Received:
    64
    Trophy Points:
    28
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    HI,

    We've opened case CPANEL-1429 to track this. Thanks for the report!
     
Loading...

Share This Page