Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

mod_userdir exclusions not working

Discussion in 'General Discussion' started by santrix, Nov 22, 2010.

  1. santrix

    santrix Well-Known Member

    Joined:
    Nov 30, 2008
    Messages:
    223
    Likes Received:
    2
    Trophy Points:
    68
    Hi,

    If I check the "Enable mod_userdir Protection" box in

    Main >> Security Center >> Apache mod_userdir Tweak

    then sure enough, the /~username URLs stop working.

    However, if I exclude protection from a couple of accounts (checking the box next to the primary account domain names only) - then I still cannot access the URLs. Is there something I'm missing here?

    Steve

    p.s. I should add, this is WHM 11.28.45
     
  2. santrix

    santrix Well-Known Member

    Joined:
    Nov 30, 2008
    Messages:
    223
    Likes Received:
    2
    Trophy Points:
    68
    OK found answer :

    1.) tick the user account you want to allow access
    2.) put the username in the "Additional Users" box at the top - i.e. next to the DefaultHost (nobody) entry
    3.) DON'T tick the exclude protection box for the DefaultHost (nobody) entry

    Submit the changes... voila!

    Steve
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice